ABS Light and Parking Brake Light

Discussion in 'Maintenance' started by RickT4098, Oct 12, 2016.

  1. RickT4098

    RickT4098 New Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 12, 2016
    brake switch.jpg


    2004 GMC Sierra 2500 HD

    I have a problem I will just first explain what happen, My Friend ask me to see if i could tell where the squeaking sound was coming from on one of his rear wheels, So I took off the wheel and hub and sprayed brake cleaner on the brake caliper and brakes, I did not remove them. And just did the side he said the noise was coming from.

    So then I test drove the car for around a mile and did not hear a sound after spraying cleaner on that one rear brake and caliper.

    here is the Problem I live on a hill so I was afraid to just leave it setting without putting on the parking brake which is in the floor...

    That is when the problem began, after driving it the next day up the road, I noticed the abs light and brake light was flickering off and on... then eventually both stayed on and now they will not go off.

    I thought this has to be a parking brake switch issue since that was all I did it push in the parking brake.

    I tested it today and it is only one ground wire going to the switch, so I hooked up my test light to the metal on the switch and the other end to a positive wire

    when i press down on the parking brake the light on my test light comes on... when i release the parking brake after some adjustment of the switch so it will get good contact with the parking brake the light goes off when released.

    But still the abs light and the parking brake light is on... Do you think the switch still could be bad? cause I do not know what else could of just happened just by merely pushing in the parking brake to keep it from rolling down hill.

    Any Advice would sure be appreciated... Thank you
     
    Last edited: Oct 12, 2016
  2. RickT4098

    RickT4098 New Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 12, 2016
    no comments?
     
  3. Kids-at-Wawa

    Kids-at-Wawa GMFS Member

    Age:
    33
    Posts:
    906
    Likes Received:
    111
    Joined:
    May 17, 2010
    Location:
    SNJ
    Scan it and get the abs codes.
     
  4. RickT4098

    RickT4098 New Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 12, 2016
    I had checked the codes when this first happened and was getting the code U1041 means that the other computers have lost communications with the EBCM.



    Then I cleared the code to see if it returned, so far the code has not returned but it also did not help in the abs light are the parking brake light to go off.

    I do not think it has abs sensors in the rear cause there is no electric wire going to either side of the wheel in the rear?


    and like I said it is strange after cleaning only the rear passenger side brake and rotor off which was the side he said was making the noise, I test drove it and it was fine ... Then when I came home I put in the parking brake and the next day driving it the two lights started blinking, and now there on all the time.
     
  5. kids-at-711

    kids-at-711 Sexually identifies as a shopping cart.

    Posts:
    2,981
    Likes Received:
    930
    Joined:
    Oct 28, 2012
    Location:
    Where Bath Salts flow freely
    The rear abs sensor is on the tailshaft of the trans.
     
  6. Kids-at-Wawa

    Kids-at-Wawa GMFS Member

    Age:
    33
    Posts:
    906
    Likes Received:
    111
    Joined:
    May 17, 2010
    Location:
    SNJ
    ABS codes usually start with a C. Is the scanner youre using able to read ABS?
     
  7. RickT4098

    RickT4098 New Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 12, 2016
    yep my scanner says abs then scans and does not pick up any codes for it... when there was a code it was U1041 but then I erased the code then drove the truck to see if it came back, the code didn't come back but yet the two lights are still on the truck... I would not think it was a abs sensor are my scanner would pick it up, and the engine light would be on to let me know that the computer picked something up with a sensor, firing, fuel..etc... It has me stumped... There was never this problem in all the time of him owning the truck... He said he never once used the parking brake, but when I used it that day the two lights went crazy flickering, and now there both staying on all the time...
     
  8. RickT4098

    RickT4098 New Member

    Posts:
    5
    Likes Received:
    0
    Joined:
    Oct 12, 2016
    well so far another day of no luck, I have went over the truck with a fine tooth comb..lol... cleaned all the brakes again, cleaned the front abs sensors, and made sure the teeth was good on the reluctant wheel everything seems fine to me.... did another scan with my scanner No codes.

    waiting on the guy that owns the truck to show up with parking brake switch though I do not think that will do any good either.... I cannot believe i cannot get at least the parking brake light to go off.
     
  9. oxsign

    oxsign '10 AVY Z71

    Posts:
    338
    Likes Received:
    3
    Joined:
    Jan 19, 2007
    Location:
    Orlando
    Any luck with this??
     
  10. Phildirt

    Phildirt n. fil-dert.

    Posts:
    1,684
    Likes Received:
    978
    Joined:
    Oct 5, 2016
    Location:
    Jacksonvile Flarda
    Unplug the brake pressure sensor on the proportioning valve. If the brake light goes out replace the sensor. I had this happen but it wasn't showing up on scan. $9 fix. There was no sensor listed for my 05, just the whole valve but I bought one for an 02 and it worked.
     
  11. Phildirt

    Phildirt n. fil-dert.

    Posts:
    1,684
    Likes Received:
    978
    Joined:
    Oct 5, 2016
    Location:
    Jacksonvile Flarda
    Shit sorry responded to wrong post @RickT4098

    Read my response to oxsign maybe it will help
     
  12. Plugger49

    Plugger49 New Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Jan 19, 2017
    I have the same problem,have you had any luck? This forum is a pita,it keeps stating-a problem has occurred,over and over over again
     
  13. Plugger49

    Plugger49 New Member

    Posts:
    7
    Likes Received:
    0
    Joined:
    Jan 19, 2017
    RickT, have you had any luck with that light problem??
     

Share This Page