shaky front end

Discussion in 'Engine & Performance' started by hagan525, Jul 8, 2009.

Sponsored By: Black Bear Performance
  1. hagan525

    hagan525 GroundeD 4 LifE

    Age:
    32
    Posts:
    1,234
    Likes Received:
    0
    Joined:
    Jan 21, 2007
    Location:
    clarksville, TN
    alright need some advice when i accelerate real fast or go over 60 miles an hour my front end shakes pretty good. what is going to cause this it didnt do it before. maybe a wheel bearing or something along those lines??? It is a bagged truck any input is greatly appreciated..:hmm:
     
  2. Jameson

    Jameson GMFS Military Member

    Posts:
    10,899
    Likes Received:
    1
    Joined:
    Nov 3, 2007
    Location:
    Fort Bragg, NC
    are yo wheels balanzed?
     
  3. hagan525

    hagan525 GroundeD 4 LifE

    Age:
    32
    Posts:
    1,234
    Likes Received:
    0
    Joined:
    Jan 21, 2007
    Location:
    clarksville, TN
    yeah they are i just did them like 3 weeks ago
     
  4. hagan525

    hagan525 GroundeD 4 LifE

    Age:
    32
    Posts:
    1,234
    Likes Received:
    0
    Joined:
    Jan 21, 2007
    Location:
    clarksville, TN
    anyone else???
     
  5. Covah

    Covah GMFS Senior Member Staff Member

    Posts:
    5,417
    Likes Received:
    16
    Joined:
    Nov 3, 2005
    Location:
    East Coast
    Take your hand off the steering wheel when driving on the highway. Do this several times in the left and right lanes ( A lot of roads are pitched to aid rain run-off ). Does it drift to any side?
     
  6. 976booboo

    976booboo GMFS Member

    Posts:
    50
    Likes Received:
    0
    Joined:
    Mar 19, 2009
    Location:
    fl.
    Check your tires i had that happen to me before and i had a big bump on the inside of the tire that came out of no where. Just takes a min. =)
     
  7. hagan525

    hagan525 GroundeD 4 LifE

    Age:
    32
    Posts:
    1,234
    Likes Received:
    0
    Joined:
    Jan 21, 2007
    Location:
    clarksville, TN
    tried it all checked everything it only does it after 65 miles an hour it seems. Would the wheel bearings cause this it makes my bagged truck rock back and forth and i dont have side to side
     

Share This Page