GMC Truck Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
6,108 Posts
Discussion Starter #1
I have had my Cats off for over a year, and I have had
wait4meperformance tune for 4 years. I haven't had any issues with my cats being off because I had them deleted from the ECU tune.

NOW for some reason my check engine lights is on! I had it scanned and it said the my 02 wires were messed up or blown fuses. No such thang has happend.

Have any of you guys with no cats and them tune deleted, have you hit a bump or something and had the tuned ECU mess up?

Thanks i'm sure that is a stupid question but i can't figure it out!
 

·
ΜΟΛΩΝ ΛΑΒΕ
Joined
·
8,527 Posts
The code is P0135
Thats front drivers side o2 heater circuit malfunction (bank 1/sensor 1), has nothing to do with your cats/rear o2's being deleted, you still have your front 2 o2 sensors. That sounds like to me that o2 sensor has gone bad and needs replaced.

Probably noticed poor fuel mileage from running rich since?
 

·
ΜΟΛΩΝ ΛΑΒΕ
Joined
·
8,527 Posts
yes that was another concern about the MPG. Which side is bank 1? should i replace both of them?

ps. you coming to the nc meet next month?
Thats front drivers side o2 heater circuit malfunction (bank 1/sensor 1), has nothing to do with your cats/rear o2's being deleted, you still have your front 2 o2 sensors. That sounds like to me that o2 sensor has gone bad and needs replaced.

Probably noticed poor fuel mileage from running rich since?

Drivers side! Common.
:shake:

And I doubt I'll be able to make it, I'll be back in Statesville by then and hopefully working.
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
If you're replacing one, replace both. Truck has some miles I would assume since it's an '03.
 
1 - 13 of 13 Posts
Top