GMC Truck Forum banner

1 - 4 of 4 Posts

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
Discussion Starter #1
Ok - dont even ask why but heres my situation. ASM headers into a Y pipe and THEN into a single cat. 2 o2s are plugged into the header but like way to far away from the cats I think. The rear 2 not plugged in at all. What do I need to do to get this shit to run right? No I cant put it back, its staying like this and I need to make it work! Use 02 sims? Where can I get them? HELP ASAP!!!!!
 

·
03 Tahoe
Joined
·
1,364 Posts
I'm not totally sure what you are asking but...

There should be 3 or 4 sensors I believe. 2 pre cat that check air/fuel ratio and either 1 or 2 post cat that check to make sure the cat or cats are functioning properly. You cannot simm the pre cat sensors....they are a complete necessity. The post cat sensors can be removed and replaced with simms. There are a few companies making them...I've got mine from casperelectronics.com

Cameron
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
With the rears out, you'll only get a Catalyst Inefficiency CEL...just annoying light in the dash. You can get an O2 Simm that are about $90 for a pair I believe or if you're tuned...get them turned off on your PCM.

You NEED to have the fronts in the header collector to maintain A/F at cruise speeds...
 

·
Registered
Joined
·
342 Posts
I got 02 sims from summit, and they sent the wrong ones. Go under your truck, mine has black plugs but the 2002 truck has either black or grey. They didn't ask me this, so i had ot send mine back and have them ship the right ones. I"ll let u know how they work once i get them back. The ses light comes one when the two back ones aren't hooked up. Some people say the make the truck run rich, and others say it doesn't affect it they only check if the cats work. I have an aftermarket fuel pump, so i dont know if that makes my truck run a little rich, or if its the 02 sensors not bein hooked up. i'll know in a week or so
 
1 - 4 of 4 Posts
Top