GMC Truck Forum banner
1 - 20 of 33 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Truck was sitting for 4 years I'm getting code po300 an code p0171 I replace plugs wires coil packs throttle body air intake still is running rough an smoking can anyone tell me wats wrong with this fucking truck
 

·
I have t-rex arms
Joined
·
353 Posts
Have you done the front O2 sensors?

Has it run at all in 4 years or just sat? I wonder if your rings aren’t seating and you’re getting blow-by, which is causing the smoke.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Yes I change all fluids before attempting to start I was told i ran once or twice a month when it sat so I don't Ashley know if they were running at those for years I haven't done anything else except what I've listed should I try the O2 sensor before the cat on driver side? Already spent a lot of money guessing
 

·
x3 shitbox owner
Joined
·
3,968 Posts
Yes. Primary O2s are what control your fuel trims and AFR and what not.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
I bought it from a mechanic he did the rear brakes and they never came back for it and it just sat in his lot for four years he sold it to me for $600
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #9 ·
I've narrowed it down to fuel or O2 sensors vacuum lines tested good and I smoke tested the intake manifold an no leaks
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #16 ·
Okay before I spend 200 dollars to have truck looked at by shop anyone got any other ideas
 
1 - 20 of 33 Posts
Top