GMC Truck Forum banner
1 - 8 of 8 Posts

·
Stay Gold!!!!
Joined
·
6,522 Posts
Discussion Starter · #1 ·
Truck is an 08 GMC Sierra 3500HD

So I bought 2 pair of LED turn signal/parking lamp bulbs from retro-solutions, and got a couple pair of the load resistors for turn signals.

I found the turn signal wire at the headlight, and tied the resistors in, and they don't seem to work, or I"m not doing something right. I tried with 1 resistor on the blue/white wire before going into the headlight harness below the light housing. I also tied in 2 of them at each turn signal into the brown wire (both showed alternating 12V with a meter while turn signal is blinking).

Neither method seemed to work.

The diagram for the resistor shows to ground 1 end, then tie the 12V side of the lamp to the other end of the resistor.

Any advice?
 

·
Registered
Joined
·
4,161 Posts
Did you start the truck or just test them with the key on? Turn the parking lights on and see which wire has constant voltage, then you can elinate that one as the signaling circuit. On mine the blue/white is the signal, but on 1500 GMCs it seems to be the brown wire. So I would figure that out first.
 

·
ΜΟΛΩΝ ΛΑΒΕ
Joined
·
8,527 Posts
Why not just ditch the hacking wires with the load resistors, and suck it up and go to the dealer to have the C&C/ZW9 program flashed in the BCM to correct the hyperflash? Any dealer that works with body upfitters will know exactly what to do. It should cost the normal ~$75 hourly shop rate to hook up to the techII and flash the BCM, but worth it IMO.
 

·
Registered
Joined
·
3 Posts
Why not just ditch the hacking wires with the load resistors, and suck it up and go to the dealer to have the C&C/ZW9 program flashed in the BCM to correct the hyperflash? Any dealer that works with body upfitters will know exactly what to do. It should cost the normal ~$75 hourly shop rate to hook up to the techII and flash the BCM, but worth it IMO.
 

·
Registered
Joined
·
3 Posts
[QUOTE="A. Delaossa, post: 6131836, member: 106972"
I have a 2009 GMC Sierra 1500, I put LED turn signals in the front and then added the resistors and they worked fine with no hyper flash. Then I added later on the running board lights with sequential turn signal with and without load resistors, and after I did that hyper flash started again. No matter what I did the hyper flash kept going at one point if I had my parking lights off and put the turn signal on it did not hyper flash but when I put the parking lights on it would hyper flash. Are you telling me if I take it to the GMC dealer they can program my PCM to work with the LED lights?
 
1 - 8 of 8 Posts
Top