GMC Truck Forum banner

08 Silverado Dim/Off Dual Climate Display

6537 Views 6 Replies 6 Participants Last post by  Cainsmill
As the title states, i have an 08 NNBS silverado, and today all the sudden the little screen displaying the temperature for my climate control is basically off Well its very very dim, if i have my face right up against it i can barely see some illumination coming from the LCD screen...

Ive done some searching around and i see alot of fixes for these for previous model years, but not so much for the new style.
Can this be fixed by disassembling the unit and replacing LEDs, or do i have to replace the entire climate control unit.

Btw, THIS is the cluster im talking about.
1 - 7 of 7 Posts

· Registered
Joined
·
1 Posts
Did you ever find a fix for this?

I came up with my own fix after researching for about 4 hrs on the same common problem occurring with the Chevrolet Corvette. Although the corvettes display was much different. So what happens is over time heat from the radio above, will cause the small resistors on the board inside the hvac control to lose connection and so all you have to do is re-solder the terminals in each of the resistors. On the corvette board the resistors are all in the center on this one they are all on two sides I will include some pictures for reference since I couldn’t find anything on this particular control.


The 10 resistors are circled in red and as you can see I re-soldered them and display works good as new! Hope this helps!!!
 

· Registered
Joined
·
1 Posts
I can confirm that the fix described by Adye6644 works.
I did it he described, took about 25 minutes from start to finish. HVAC cluster is fully visible in broad sunlight.
Thank you for saving my family time and money!
 

· Registered
Joined
·
6 Posts
Thanks again to Adye6644 for this information and for Slent verifing it. My son just purchased the new style 2007 Silverado 2500HD Crew Cab Durmax 4wd and this is one of the many minor issues that I'm helping him to correct/fix. It looks the same as the unit in the pictures. When I get some time, I'll check the solder joints. I had to do basically the same thing but to the instrument cluster in my son's 03 K1500. Thanks again for the info.
 
1 - 7 of 7 Posts
Top