GMC Truck Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a 1996 z71 truck ac compressor will not engage. I have already swapped the compressor dryer and Orphis tube out and charged the system but my compressor will not kick on unless I by pass my relay the relay works tried on my 98 c1500, I have tried to bypass one switch at a time on the top of the compressor and the one at the dryer neither would let it kick on. I have also swapped out the ac control module in the dash with one I know for a fact works, what else could it be when it’s bypasses it blowed super cold
 

·
Premium Member
Joined
·
377 Posts
I'm having the same issue with my 06. Pretty much narrowed it down to a bad wire somewhere between the controls and that relay. I've replaced all the components same as you and compressor will still only cut on when I jumper across that relay.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I'm having the same issue with my 06. Pretty much narrowed it down to a bad wire somewhere between the controls and that relay. I've replaced all the components same as you and compressor will still only cut on when I jumper across that relay.
If you figure yours out let me know lol I’ll do the same for you I am going to try splicing a long wire from the switch in the dash to the relay and check to see if the wire got cut somehow
 

·
Registered
Joined
·
663 Posts
If jumping the relay works, then you are not getting power to the relay on the coil side or you are not getting a ground signal from the VCM/PCM (wire should be dark green with a white tracer) the red connector pin 9.

I would start there and work my way back through the controls side.

http://lt1swap.com/1996_vortec_5.7/ac_5.7.gif
 
1 - 5 of 5 Posts
Top