GMC Truck Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi all,
Factory radio died so I thought I would put in an aftermarket ..
All went in easy enough but now I have no rear speakers and the front are super quiet and sounds like no base...

Did some Google detective work and it sounds like the amplifier. I went to the fuse box and pulled the amp fuse and it makes no change in the sound so I believe this confirms the amp.
Now, to find the amplifier. I have no center console just the flip up armrest and bench seat.
A little more Google and I am looking behind the glovebox...Silver metal box looks promising buy I am told that is the XM receiver (pic attached).
So that being said, where is the amp?
Any thoughts please?
Many thanks in advance
Poccur
 

Attachments

·
Registered
Joined
·
538 Posts
Was the factory system Bose? Did you use a harness adapter to wire up your radio, or did you hack into the truck's wiring harness?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
It was factory standard radio....Used adaptor for the radio but it is wired right....reason I changed the factory radio was the sound was dead with no bass....changed to new system and have exact same sound...pulled amp fuse and no change so I am thinking amp has died...just cannot find amp...
No center console so not under there...nothing in glove box except for XM radio receiver....so where else can it be?
Thanks
 

·
Registered
Joined
·
538 Posts
Well, let's see:

-there are several different factory standard radio's, some with separate amps, some without
-depending on what the original factory radio was, different harness adapters are needed for aftermarket radios to properly connect up
-have you considered that your truck doesn't have an amp, but instead there is wiring and/or speaker problem/s
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Well I had exact same symptoms with the factory unit....I see your point, perhaps I should be looking at speakers...
Would it be helpful if I posted a picture of the factory unit to determine if there would be an amp?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Well, let's see:

-there are several different factory standard radio's, some with separate amps, some without
-depending on what the original factory radio was, different harness adapters are needed for aftermarket radios to properly connect up
-have you considered that your truck doesn't have an amp, but instead there is wiring and/or speaker problem/s
Additionally, I have an fuse labeled AMP in the fuse box....
 

·
x3 shitbox owner
Joined
·
4,252 Posts
Does it have the Bose speaker grilles on the front door panels?


Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
Top