GMC Truck Forum banner

81 - 96 of 96 Posts

·
x3 shitbox owner
Joined
·
3,275 Posts
Did you ever figure out the issue with the random lean spikes?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
693 Posts
Discussion Starter #84 (Edited)
123.jpg

No pictures but I'm making steady progress. I'll try to get some today

Front is back together for the most part. Still waiting on hubs, and rotors which should be here today. Spindles and struts are in as well as new ball joints and end links. Tie rod ends will be here tomorrow.

Rear is flipped and laying in place. Everything is bolted up minus u-bolts which will also be here today.

While I had some time at work I powder coated my new brake dust shields.. I'm trying to keep everything clean in there as I can.

1234.jpg
 

·
Registered
Joined
·
693 Posts
Discussion Starter #85
Well its on the ground. Again, not many pictures because I was running around trying to get it finished and it was dark out by then. Only thing left is to install the transmission spacer and new tie rod ends.. and go back and recheck everything.

These are the only three pictures I got yesterday... crappy but it gives an idea.

IMG_8494.jpg

IMG_8496.jpg
IMG_8497.jpg


I'll definitely get more today.
 

·
Registered
Joined
·
693 Posts
Discussion Starter #89
Mike I think you're right now that I look at it... I still need to put the hitch back on and put the spare back under it.

And I think it sits nicely.. however a 4/6 is a pretty simple adjustment now lol
 

·
n. fil-dert.
Joined
·
6,836 Posts
Looks faster
 

·
Registered
Joined
·
693 Posts
Discussion Starter #91
Truck hasn't been getting driven much recently. Been to busy with other projects that I haven't had time to work on this. However the truck did settle mucho as time went on

868482


Went ahead and ordered up some parts for my exhaust. New y-pipe from speed engineering, some flanges as well as some other bits and pieces. Gonna tig some 3 bolt flanges up to the headers and y-pipe and scrap this garbage true dual kit from speed engineering. No matter what I cannot get it to fit right and cannot stop it from leaking

Looks like I'm going to go with a corsa setup.. always did like the way they sound/look. The tip is much better than the far spread tips on the SE kit.
 

·
Registered
Joined
·
693 Posts
Discussion Starter #93
Way down the road.. I may just put a hd hood on it and paint the grille/bumper and call it
 

·
Registered
Joined
·
693 Posts
Discussion Starter #95
That was an option, however it’s so jank it’s embarrassing.

There 3 different areas where the pipes hit the frame, I had to modify the xpipe for it to even fit, mufflers blew out a good amount of packing and now rattle like shit. Right at the X crossover there is a cracked weld from I’m guessing heat and stress. Not my weld but speed engineerings.

Nothing I can’t fix, but I’d just rather do it over, do it right, and have a good sounding setup.. like they say do it right the first time.. however I did not lol

Also I’ve tried emailing speed engineering about all the quality issues I’ve had, and they told me to go pound sand. I wish I still had the emails because they were actually pretty funny


Sent from my iPhone using Tapatalk
 
81 - 96 of 96 Posts
Top