GMC Truck Forum banner
1 - 20 of 49 Posts

· Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
I have a 2012 Silverado 5.3L with AFM tuned out. The truck starts up fine when cold. It does have a surge of idle when coming back to a stop at idle but not when you roll off the throttle cruising. Also, when the vehicle is warmed up and you try to start it after letting it sit for a little it'll be hard to start. The cranking is extended until it fires then the idle is pretty low like 400 then it surges to normal and it's ready to go. I have an advanced scanner I picked up to help diagnose this problem. Not sure how to read all the data. Please help with tackling this issue. I've seen so many threads online with similar issues with no resolutions! Thank you!!!!

Pic of my truck
 

Attachments

· The great white Canadian
Joined
·
2,114 Posts
A friend had a similar issue with his 2009. It ended up being a fuel pressure issue. He replaced the filter, pump, regulator and injectors all at once. I don't think they were all the problem, he's just the 'while I'm here' type of guy. So I can't say for sure what his problem actually ended up being. He also replace the cam and lifters, again because he was there. We did it all in one weekend, rather than have the truck down multiple times.
 

· Registered
Joined
·
25 Posts
Discussion Starter · #7 ·
Well some good news, the truck finally threw a check engine light. I scanned it and it reads P0107 - MAP Sensor. I will get it replaced and report back in a couple days. I want AC Delco and no one stocks it so I have to order it online. Stay tuned.....
 

· Registered
Joined
·
25 Posts
Discussion Starter · #9 ·
I ordered one off Amazon for 12 bucks, it's coming this weekend, I'll install it and report back. The MAP is on the back of my intake as I have a Holley Intake...doesn't look like fun to get to it...
 

· Registered
Joined
·
25 Posts
Discussion Starter · #10 ·
I ordered one off Amazon for 12 bucks, it's coming this weekend, I'll install it and report back. The MAP is on the back of my intake as I have a Holley Intake...doesn't look like fun to get to it...
 

· Registered
Joined
·
125 Posts
Hey how did it go???? I’m having similar issues on my 2008 z715.3.. Sometimes it struggles to start.. I replaces fuel pump, spark plugs, wires, cleaned tb body, replaced filter, starter, now I’m running out of ideas… seems to struggle less when I give it gas when I start it… let me know how it went thanks!
 

· Registered
Joined
·
3,161 Posts


That’s some extremely high Alcohol content.
 

· Registered
Joined
·
3,161 Posts
Looks like you just run E85 in a stock flex fuel truck. It’s hard to light e85.
 

· Registered
Joined
·
3,161 Posts
Yeah I run E85 Flex Fuel, so that seems okay right?
Yea, forsure. Everything seems spot on perfect for a factory flex fuel vechical runing E85. Factory Flex were made to only be capable of running E85 as a cheap alternative to E10 gas when needed. Not become a Race car and take advantge of Its high octane rating.

-4/5 STFT, 49.77991kpa map, 1 lamba commanded at 147degrees. Only thing i see off is the 62% alcohol, that is really low for e85, and 18 degrees of timing, thats pretty high for E85. So your either mixing fuel, getting bad fuel. Plus some pretty fowled and weak plugs for it to command 18 degree of idle advance with 62% alcohol.

Stabilitrac and/or traction control lights on?
 
  • Like
Reactions: brarei200

· Registered
Joined
·
25 Posts
Discussion Starter · #20 ·
The stabil/trac light was on but it went off when I fixed the MAP sensor code. I may have mixed fuel when this scan was taken. I been running straight E85 from Sheetz since I get the same gas mileage with regular fuel. Not sure what 18 degrees of timing is. Should I change my plugs and wires?
 
1 - 20 of 49 Posts
Top