GMC Truck Forum banner

1 - 4 of 4 Posts

·
TRUCKMODCENTRAL.COM
Joined
·
574 Posts
Discussion Starter #1
My brother and I bought a 1999 Chevy Silverado 3500hd with the 6.5L Turbo Diesel for our Landscape company..

Well needless to say we are having a little trouble with the 4L80E...

When driving about 45-50 it seems that we lose 4th (Overdrive) And it will go back and fourth from 3rd-4th.. Sometimes it just stays in 3rd and others its normail...


Is this something that a 3rd-4th Solenoid being replaced would fix the problem? Or is there some kind of electrical/modular unit on the tranny that might need replaced???

Any Ideas.?

Thanks in advance
 

·
Registered
Joined
·
317 Posts
I would try a fluid and filter change first, but its likely the band is slipping. A new larger servo may be a bandaid for a while. Is this while loaded, maybe the load is too much for you to be pulling in overdrive.
 

·
TRUCKMODCENTRAL.COM
Joined
·
574 Posts
Discussion Starter #3
I would try a fluid and filter change first, but its likely the band is slipping. A new larger servo may be a bandaid for a while. Is this while loaded, maybe the load is too much for you to be pulling in overdrive.
I does this when empty more commonly than when loaded. We added more tranny fluid cause it was at 3/4 full it seemed to help... It acted up this morning but it was fine this afternoon..
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
I would try a fluid and filter change first, but its likely the band is slipping. A new larger servo may be a bandaid for a while. Is this while loaded, maybe the load is too much for you to be pulling in overdrive.
WTF, the 80E doesn't use a band for overdrive.



 
1 - 4 of 4 Posts
Top