GMC Truck Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Just had my truck lifted by a rough country dealer/installer. Lift came out great. 2015 Silverado 1500 LTZ with 51k on it. Was the 5 inch bracket lift with lifted struts and mono rear shocks. Rides better then stock. However used 4wd today, lift was just put on 75 miles ago, noticed a vibration at 35+ MPH. Took it back to installer. Put truck on lift and found noise was coming from Tcase. Removed front drive shaft and ran in 4wd and noise is still there. Any thoughts ? Dealer is contacting Rough Country tomorrow
 

·
Registered
Joined
·
183 Posts
Idea. Post a pic of the suspension from the front. Need a straight view of the lower control arms and cv axles. Then turn the wheels and post a pic looking into the wheel well.

Sent from my LG-G710 using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Idea. Post a pic of the suspension from the front. Need a straight view of the lower control arms and cv axles. Then turn the wheels and post a pic looking into the wheel well.

Sent from my LG-G710 using Tapatalk
I will get pics tomorrow. With the bracket lift all the geometry stays close to stock with front diff and control arms and such. Just weird to have the noise come from transfer case right after lift instal. Hopefully Rough Country has some answers.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Idea. Post a pic of the suspension from the front. Need a straight view of the lower control arms and cv axles. Then turn the wheels and post a pic looking into the wheel well.

Sent from my LG-G710 using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Yeah, just crappy timing I guess. Always something. I have the worst luck. Now just have to see if my warranty will fix it. Only had the truck 8 months. Its my daily
 

·
Registered
Joined
·
183 Posts
I doubt its lift related because your angles are flat. Pretty good actually. Yeah its just a coincidence. I deff get it checked out tho. Good luck to ya man!

Sent from my LG-G710 using Tapatalk
 

·
Married and broke
Joined
·
1,847 Posts
They also didn’t drill a second hole in the lower control arm to relocate your swaybar end links inward to keep them vertical.
 
1 - 13 of 13 Posts
Top