GMC Truck Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1,158 Posts
Discussion Starter · #1 ·
Right now im working on a 96 Suburban with a 350tbi. It will turn over but will not start. Gets good spark and good fuel pressure at the test port in the rail. It can be started with tons of starting fluid in the intake and will stay running just fine but will not start on its own. I think it might be one of the injectors but how will I test that, has anyone had this problem, and what was the solution?
It has no check engine light and a brand new fuel pump.
 

·
CHIMICHANGA
Joined
·
3,275 Posts
Firing order, fuel filter?
 

·
JUGS Racing
Joined
·
1,199 Posts
96 with TBI? Its a vortec if its 96. Whats the fuel pressure at? Also it will stay running indefinately or until it runs out of the starting fluid?
 

·
Registered
Joined
·
1,158 Posts
Discussion Starter · #6 ·
Whats the fuel pressure at?
It drops over night so I let it sit over night and got the readings this morning.

Hooked the gauge up to the test port with key off and it read 0kpa. Turned key on and it read 60kpa, then dropped to 46kpa. It stayed at 46kpa while it was turning over trying to start.
 

·
Registered
Joined
·
1,158 Posts
Discussion Starter · #8 ·
Another question about the same suburban, The radio will come on but will not play music. It has all factory speakers and the factory headunit out of my 99 in it. When you unplug it and plug it back in it will play music for a split second and then stop. What would that be?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top