GMC Truck Forum banner

1 - 20 of 33 Posts

·
Registered
Joined
·
635 Posts
Discussion Starter #1
Just wondering what kind of warranty work everyone with a 1999-2004 has had? If you you haven't had any feel free to post that up to. THANKS!!!! If you could post it up like this........

1.) WHAT YEAR AND ENGINE?
2.) HOW MANY MILES?
3.) WHAT WARRANTY WORK?
 

·
Registered
Joined
·
635 Posts
Discussion Starter #2
I guess I'll post up first.

1.) 2003 5.3L V8
2.) 7340 Miles
3.) One Reverse Bulb
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
1) 5.3
2) 16ish??? Cant remember
3) Starter went out on me. They were a bitch about replacing it because I removed it and they were trying to claim I broke it. I walked out into the lot with a wrench and said I would show them on a new truck that I could remove it without damaging it and just trade them out right then if they didnt mind. They then agreed to warenty it.
 

·
Line-X of San Antonio
Joined
·
5,237 Posts
1)02 5.3
2) 28K
3) new drivers power window motor, new regulator, new windshield weather stripping, new door weather stripping. ex windows readjusted for windnoise.

new taillight at 10K mi right before the 03 tail swap. clip broke.
 

·
Registered
Joined
·
2,172 Posts
1. '99 5.3 Z71
2. 101K
3. Broke my engine wiring harness 3 times, first time under warranty, next two not under warranty. New steering shaft at 15K. Had my brakes tightened numberous times under warranty. Passenger side regulator.
4. Fixed not under warranty - Just the other day the driver side regulator. New tranny at 82K. U joints at 40K. My bed is cracked all over (needs to be replaced).

That is all I can think of right now.
 

·
Registered
Joined
·
1,997 Posts
04 5.3
3K
Lets see, it hasnt been in for work, but the other day it said my Brake Booster needed to be serviced? I was like what the fuck, and I have had an issue of it being powerless, but we think its from a low battery from the Responder install...Shop recharged the battery and it drove fine, and only did it one other time when I had my sub going without it started... Hopefully that is the deal...
 

·
Just Cruz'n
Joined
·
133 Posts
2000
4.3L V6
Just went over 70,000

Carbon build up in the injectors had to take it in because SES light came on and it ran like crap, water pump replaced and then had to take it back because they installed the gasket wrong, high beam toggle lever replaced along with some wiring to the headlights, intake manifold gasket replaced, thermostat housing gasket replaced, just recently replaced the serpentine belt, and I think that is about it.
 

·
Registered
Joined
·
308 Posts
01 4.3 with 24500 miles....rear brake line bracket on passenger's side not bolted properly to frame, caused god awful squeeking...and the worst one, condensation from a/c lines that run to condenser over top of distributor dripped on to cap and over time caused the cap to arc, with caused the damn thing to miss and finally not start after i got to the charlotte airport after coming back home to texas for a few days....that sucked waitin for 3 hours on the damn gm roadside assistance.
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
captainchaos said:
01 4.3 with 24500 miles....rear brake line bracket on passenger's side not bolted properly to frame, caused god awful squeeking...and the worst one, condensation from a/c lines that run to condenser over top of distributor dripped on to cap and over time caused the cap to arc, with caused the damn thing to miss and finally not start after i got to the charlotte airport after coming back home to texas for a few days....that sucked waitin for 3 hours on the damn gm roadside assistance.
Same exact thing with the dist. happened on my friends 00 v6. i cleaned it out real well and then put some wire loom over it so it drips on either side. Fixed it. There is a TSB on this and thats the fix that they do.
 

·
Changed my life
Joined
·
1,218 Posts
1.)2002 5.3
2.)22,000 miles ( :bawl: )
3.)Squeaky intermediate steering shaft. Greased it up, no other problems to speak of.
 

·
Registered
Joined
·
2,318 Posts
1. 1999 4.3
2. 77,000miles
3. At 73k water pump went out, thats about it
 

·
Registered
Joined
·
276 Posts
1. 2002 5.3
2. 148500 Miles
3. warranty went out a few thousand ago, but had no trouble until the warranty went out, then had to replace idler pulley, and fixen to replace knock sensors, but that is how it works
 

·
Must be lost..
Joined
·
1,148 Posts
04 5.3

30k

Had the rear doors adjusted because they kept creaking, and other then that just the basic recalls. I need to take it in for the intermediate shaft when i get some time though.
 

·
Registered
Joined
·
45 Posts
05 5.3
13k

Rear doors were creaking

Havent taken it in for this yet but probably should. The exhaust makes a shitty vibrating sound when I take off.
 

·
GM Loyal
Joined
·
1,335 Posts
1. '04 5.3l
2. ~24,000 miles
3. intermediate steering shaft needed lube. Now with just over 36K miles its starting to feel like its gonna need it again soon. Guess I'll be fighting this one for as long as I own the truck.
 
1 - 20 of 33 Posts
Top