GMC Truck Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Okay heres the problem my ac has worked great, but now it seems that the temp knob isnt activating whatever its supposed to, the compressor is working fine but it just blows heated air no matter where its at.:think:
 

·
Registered
Joined
·
544 Posts
Is your heater control valve stuck open?
 

·
Registered
Joined
·
147 Posts
Mine does the same thing.. Wondering what the fix is for it. I thought it was maybe just the switch. Mine seems like whatever temp you start the truck at is where it stays...
 

·
Registered
Joined
·
3,382 Posts
Mine does this also. And its the heater control valve. I've had mine replaced 3 times and now its messed up again. Whats the fix for this whitout going to gm?
 

·
Registered
Joined
·
3,278 Posts
Mine does this also. And its the heater control valve. I've had mine replaced 3 times and now its messed up again. Whats the fix for this whitout going to gm?
I have replaced mine twice as well. GM is the only one who has the actuator.
 

·
Registered
Joined
·
3,278 Posts
Replaced it. I tried to open my first one and fix it bu all of the cogs inside are synchronized and I fucked it up worse.
 

·
Registered
Joined
·
3,278 Posts
It was a year or 2 ago I think it was around 75.00
 

·
haz 12"s!
Joined
·
4,531 Posts
wow.. good thread. I have a similar problem. I can be crusing down the road with the a/c on and the on the drivers side the heater will start blowing HOT air but the a/c stays on the pass side. The only way to fix it is to turn the IGN off and restart it and all it well again. Could this be related to that valve?
 

·
Registered
Joined
·
3,278 Posts
wow.. good thread. I have a similar problem. I can be crusing down the road with the a/c on and the on the drivers side the heater will start blowing HOT air but the a/c stays on the pass side. The only way to fix it is to turn the IGN off and restart it and all it well again. Could this be related to that valve?
Sounds similar what year truck? Also see if you take off real fast if it does it or stopping real quick should do the opposite.
 

·
haz 12"s!
Joined
·
4,531 Posts
Its done it just driving down the interstate. I dont think its done it starting or stoping and its never done the opposite (going from heat to cold). Its a 04. Its probably not related then.
 

·
|=====TK=====|
Joined
·
523 Posts
I've got a similar problem on my '05. Out of the blue it will only blow hot air and there is no control over which vents it comes out (it defaults to all hot air and the defrost vents). To date I've had three actuators replaced, had a wire replaced that goes to the fuse box (they allegedly found a voltage drop between the ignition and control head), and had the fuse panel replaced. Every time the dealership works on it it seems to be good for 2 - 3 weeks, then fails again. I don't know if it's fixed yet since I just got it back again, so only time will tell. I have a feeling that the dealership is guessing at this, but I'd like to hear from even more who have had these problems. Maybe it will help somebody figure out what is wrong on their truck.
-TK
 

·
haz 12"s!
Joined
·
4,531 Posts
Im just assuming mine is the control unit since I can just turn the IGN off and back on and its normal again.
 

·
Registered
Joined
·
3,278 Posts
I replaced both the control head and the actuator fucking control head was expensive.
 
1 - 20 of 23 Posts
Top