GMC Truck Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
Ok, Ive got a 43.L 2003 Silverado. Just had a new long block put in at 89K, and now im at 123K, and I have had this problem ever since i got the truck.

Every now and then it will flash SERVICE BRAKE SYSTEM and the ABS and PARKING BRAKE Lights will come on. They never lasted long, and I could always pull off the road and restart the motor, and problem clears.

Well now they come on and stay on for a random amount of time, the PARKING BRAKE Light and SERIVCE BRAKE SYSTEM will go off and then the ABS Light will and all is clear for another random amount of time. Then the whole cycle repeats itself.

Any ideas as to what may be causing this? No noise coming from the motor when it is off, so far that means the EBCM is still good.
 

·
Registered
Joined
·
5,528 Posts
Abs module may be bad or a loose connection in the wiring. Go from the brakes ( including the wheel speed sensors ) and work your way all the way up to the module.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Can you give me an idea as to where the ABS module is?

Before it started doing this, I had to go over a curb on my driver's side and I did bottom out slightly.

The Brakes are working perfectly though, no problems at all, and I drove about 60 miles yesterday after the lights started this pattern.
 

·
Registered
Joined
·
807 Posts
the abs module is directly below the drivers door towards the front on the side of the frame rail facing in... it has the brake lines going in and out with 2 plugs going to it.
 
1 - 4 of 4 Posts
Top