GMC Truck Forum banner

1 - 13 of 13 Posts

·
Team Black
Joined
·
2,415 Posts
Discussion Starter #1
ok so my ac quit working the other day. 1st day of symptoms was the ac was blowing cold then outside air temp on and off, never blowing cold air 100% of the time. next day it doesnt blow cold at all. I dont hear my ac compressor kicking on and it does nothing when I hit the ac/fan button..still blows outside air temp.

this may be part of the problem...a while ago my hvac would never switch to fan and only blow the ac no matter how many times I hit the ac/fan button. now it seems like its doing the opposite, only blowing fan and no ac.

any suggestions? TIA
 

·
Team Black
Joined
·
2,415 Posts
Discussion Starter #2
ok so I had time to dick around with it today.

I put a guage on it..it read 10 psi. so I added a can of freon and the comp started kicking on and off every other 2 or 3 seconds (relay & comp is good). I guess it was cycling the freon into the system. so I decided to make it go faster and unplugged the wiring harness to the accumulator and bridged it and made the comp stay on while recharging.

after one can it started to blow warm, cold, warm, cold. I added another can, now it blows cold, but the comp wont shut off. yes, I took the wire off and plugged it back into the accumulator. why wont it shut off? TIA
 

·
I'm on a mission
Joined
·
794 Posts
first off, compressors cycle fast when they are low on freon-normal. adding the second can gave enough freon to run on it's own. why it is not shutting off now.. maybe incorrect freon level or electrical issue.
 

·
I'm on a mission
Joined
·
794 Posts
what side are you reading-high or low? numbers vary according to manufacture. what do you have now. i assume your charging on the low side with a bottle from the parts store?
 

·
Team Black
Joined
·
2,415 Posts
Discussion Starter #6
reading from low. I'm at about 45 psi now. yea, I filled from the low port with a r134a can from an auto parts store.
 

·
I'm on a mission
Joined
·
794 Posts
45 is about right. of course i work at a hyundai dealership and i'm basing this of ours. if you pm me with your exact year and engine size i can check monday on alldata for your specific specs
 

·
Team Black
Joined
·
2,415 Posts
Discussion Starter #8
I can do that at the shop I'm at, thanks for the offer tho. I'm just trying to get to the bottom of this. oh yea, you've been really helpfull, thanks
 

·
In Work
Joined
·
120 Posts
Get the dye 134 from Advance or I think wal mart has it also. I was lucky and had a old blacklight in the shed. Was able to diagnose my leak in about 2 secs. O ring on low pressure line was leaking. Due to the system sitting all winter and spring was bone dry, not my fault I bought it this spring. But it is a slow leak so the next time my shit gets low I will have it vaccd and do the rings it was about 2.49 for the kit from advance also. So it may be worth a shot the uv can wasnt high either. For now its still blowing cold a couple weeks later. Hope this helped a bit.
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
Throw gauges on it and tell us the high side pressure. Also, the appx ambient temps you do this at.
 
1 - 13 of 13 Posts
Top