GMC Truck Forum banner
1 - 14 of 14 Posts

·
C10 Owner
Joined
·
224 Posts
Discussion Starter · #1 ·
So I'm waiting on SD to rebuild my lower bars and decided to tidy up a few things that I have been needing to do. Changed out a fitting on the tank and I had a leak on the pass front side at the valves. After taking the fititngs out of the valves and re-assembling them I put them back on the truck and the lift valve is stuck open. I tapped it...nothing. Took it apart and checked the diaphragm (sp?) everything looked good, no debris, no moisture but it's still not closing.

These are brand new valves and i have had the front done for about a month and this is the first problem. I have not driven the truck since finishing the the front. Could i have possibly overtightened the nipple into the valve? Or do i just need to order a new diapdragm?

Here's a pic for those who take the time to try to help.



Yeah it's off a cell phone, dont hate.
 

·
C10 Owner
Joined
·
224 Posts
Discussion Starter · #3 ·
Valve is in right it has been doing fine for a month. And i took the valve off the truck and I can blow through it with my blow gun so I know it's not electrical. It just will not close. I'm stumped.
 

·
I don't own a lowrider
Joined
·
4,694 Posts
I had one that wouldn't close on my old truck once. I took it apart and cleaned it and it never stuck again.

I've also cleaned a sticky valve with WD40 with good luck in the past but try that at your own risk since I'm not sure if it'll have any long term effects.
 

·
Registered
Joined
·
1,446 Posts
sounds to me like something might not have got put back together right...usually if a new valve sticks you can hit the switch a few times and it will un stick and go to work
 

·
C10 Owner
Joined
·
224 Posts
Discussion Starter · #11 ·
is the spring in it?
Yeah the spring is in there and it looks fine

Not many people run Air lift valves... When I had a problem with my smc it was a piece of trash stuck up top not letting the valve close all the way
SD was backordered on smc's so I got airlifts. I took it apart and everything was perfectly clean

sounds to me like something might not have got put back together right...usually if a new valve sticks you can hit the switch a few times and it will un stick and go to work
I jacked with it for a good 45 minutes on and off the truck.

I have today off so i will mess with it again if it does not work would everybody suggest a new valve or new diaphragm. The valve itself is just a hunk of metal the diaphragm is what does the opening and closing.
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top