GMC Truck Forum banner

1 - 10 of 10 Posts

·
GMFS Senior OG Member
Joined
·
3,511 Posts
Discussion Starter #1
Ok I just recently added a TBI spacer on my 95 OBS 305 just to give it a little help. When stomping on the gas in first gear, then when it shifts into second gear I get a little stumble. This only happens some of the times not always. What could be the problem or have I over look something?

Here's the minor mods I've done so far:

TBI spacer
K&N air filter
Silencer box removed
Straight air tubing from the air filter to the inner fender well
Shortie headers
Hot chip
B&M electronic shift thingy

TIA
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
Timing? Plugs? Wires? Making a misfire... :think:

Are the injectors perhaps getting soiled in your TBI unit?
 

·
GMFS Senior OG Member
Joined
·
3,511 Posts
Discussion Starter #3
Hit Man X said:
Timing? Plugs? Wires? Making a misfire... :think:

Are the injectors perhaps getting soiled in your TBI unit?
Plug and wires are new. Haven't checked the timing yet.
What do you mean "Are the injectors perhaps getting soiled in your TBI unit"?
Can you explain for the old fart here. :think: Or what your trying to say is my TBI unit may be saturated with fuel?
 

·
Registered
Joined
·
378 Posts
i think it might be the tb spacer that might be pulliong to much on the linkage. every once in a while it will cause a stamble due to the linkgae being off. chaeck that first. then i would check for an intake leak. spray some brake clean around the spacer while it is running. see if the engine stumbles or not. that will get you started. if all else fails take the spacer off and use it as a paper weight.
 

·
GMFS Senior OG Member
Joined
·
3,511 Posts
Discussion Starter #5
02denali said:
i think it might be the tb spacer that might be pulliong to much on the linkage. every once in a while it will cause a stamble due to the linkgae being off. chaeck that first. then i would check for an intake leak. spray some brake clean around the spacer while it is running. see if the engine stumbles or not. that will get you started. if all else fails take the spacer off and use it as a paper weight.
After I installed it I did spray around the spacer and TBI just to see if I have any leaks, and found no leaks. How do I go about checking the linkage? And if I do take it off it would be a nice shiney paper weight. lol
 

·
Registered
Joined
·
378 Posts
i think they come with a linkage spacer. make sure that at idle there is no tension on the lines. drive it around for a while and let the pcm learn it. we have found that on the dyno it did lose one hp. good luck.
 

·
GMFS Senior OG Member
Joined
·
3,511 Posts
Discussion Starter #7
Mine didn't come with one. And yes the cable was really tight, so I lossened it up a little bit. Maybe I should lossen it up some more?
So what your saying is with this spacer I may lose about 1 hp?
 

·
HOT AIR BALLOON OWNER
Joined
·
14,932 Posts
Wait so this just happened after the TB spacer was installed? :think:

Nevermind what I mentioned then, check the install and associated bits as 02Denali pointed out. :shake:
 

·
LOW BLOW CUSTOMS
Joined
·
238 Posts
hey kal, if all esle fails, i know where theres a LT1 with a tranny and wiring harness i might could cut ya a deal on!!!
 
1 - 10 of 10 Posts
Top