GMC Truck Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,525 Posts
Discussion Starter #1
Howdy,

Last night when i got home and turned my truck off, it was still running strong at 14volts when the truck was on. Today when i started it the battery light immediately came on and the truck has been runnnin around with about 12volts when the truck is started. My dad thinks the alternator is going out...i was thinking that when i jumped my 2 friends cars and i lost the + battery terminal cover for the top post (everything is hooked up to the sidepost) maybe the positive terminal is touching something or because it got wet it's losing voltage.

Any Ideas or Solutions?

Thanks,
Dave (see sig for truck details)
 

·
Banned
Joined
·
487 Posts
12 volts should still be enough....

theres an easy way to tell if the alternator is working... get a metal screwdriver and hold it on the back of the alternator WHILE ITS RUNNING and it should be magnetized.
 

·
Registered
Joined
·
1,816 Posts
Best bet is to check the battery voltage with a meter, with the truck on and off. Off it should be around 12, running 13-14. I had a bad battery the other day, battery was 12 with the truck running, 5.8 with it off.
 

·
Broke
Joined
·
350 Posts
Id check for a dead cell in the battery. If there is a dead cell then you know you need to replace the battery, if there's not one then you prolly need to replace the alternator. Although 12 volts is enough for everything to run, it is not normal.

To check for a dead cell simply remove the caps on the top of the battery. Stick the negative end of the voltmeter/multimeter on the batterr's ground. Stick the positive lead in each cell, there will be 6 of them. The first should read around 2 volts, second around 4 volts, and so on. Each cell should be producing an extra 2 volts. There will be 6 cells, and whaalaa theres your 12 volt battery. You'll know when you hit a dead cell (if there is one).
 

·
Registered
Joined
·
2,525 Posts
Discussion Starter #5
Yeah today i was driving it back from a golf meet, oil pressure dropped from around 60 (when moving) to 40 (when moving), theres a really annoying squeek at idle from something in the engine bay, and my "service engine soon" light came on. I swear this truck is never wanting me to get things done to it. I was gonna drop it, now i prolly won't have money...sucks ass.
 

·
Pink Bear Man...
Joined
·
1,455 Posts
Another good little alternator trick. Start the truck, unhook either battery cable. If the truck dies, alternators bad, simple as that.
 
1 - 6 of 6 Posts
Top