GMC Truck Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
906 Posts
Discussion Starter #1
I was comming up to a stop light, so i lightly started pushing on the brakes, after a few seconds, my pedal got a little stiff the and the brake pedal started vibrating kinda like I was driving over a bunch of small rocks, so I let go of the pedal and pushed down again and everything was normal. Has anybody else had this problem. I checked my brake fluid and it was just a tad under the full line. Should I just take it in and get the brake fluid flushed? I had my brakes checked almost 3 months ago and my pads and rotor were perfect! I also pumped my pedal after I turned it off and it got stiff, so I know there was no air in the lines.
 

·
Masshole
Joined
·
5,276 Posts
thats your ABS. how many miles on the truck. my bet is ur ABS sensor/speed sensor on your wheel hub assembly on the front of ur vehicle has rust on them so the abs sensor is reading it and turning ur abs on. i had to replace both wheel hub assemblies when i had my 01 blazer. as far as i kno..u cant just buy the sensor, u need the whole unit. 4 wheel drive assemblies usually run cheaper then 2wd, my blazers were about $150 each
 

·
JetBlue
Joined
·
2,306 Posts
This is the regional recall issue. I've had the problem, but being a Cali car, can't get it fixed under recall. My friend w/a car from Minnesota had it, and got his covered.

-bZj
 

·
Registered
Joined
·
5,528 Posts
I just spray the sensors down with brake cleaner. They get gunk and little metal shavings on them.
 

·
Registered
Joined
·
807 Posts
I just spray the sensors down with brake cleaner. They get gunk and little metal shavings on them.
clean up them sensors and see what happens...i had mine fixed under recall, but all they did was cleaned the sensors because they werent bad just dirty and my brakes felt better after that imo.
 

·
Gringo Chiludo
Joined
·
586 Posts
That happens to me all the time, I just always thought it was the bigger tires....
 

·
Registered
Joined
·
906 Posts
Discussion Starter #8
From what I have seen so far at kragen, the sensor and hub come together, not seprate. Ill try cleaning the sensor real good first!
 

·
Registered
Joined
·
906 Posts
Discussion Starter #10
I think I am gonna call gm this morning and see if they might sell the part seprate. Fuckit, since it comes with the hub I might as well buy my drop spindles!
 

·
Weird Turns Pro.
Joined
·
6,251 Posts
i unplugged my ABS years ago :crazy:
 

·
Registered
Joined
·
906 Posts
Discussion Starter #14
I called the dealer today and they said the sensor was $130 a piece! I had them check the recall and they said there was nothing on my vehicle!
 

·
Left Jizz
Joined
·
1,225 Posts
I'm not sure about an 03, but on all the ABS equiped vehicles I've had problems with, I just pulled the fuse and it went away. Also, by putting a locker in the rear of my truck it defeates the rear abs that chevys had for a few years. Probably not the safest thing to do, but you're in cali where it doesn't snow or rain (well, not much at least) and if you know how to drive it's fine. I do realize you're dealing with front sensors too.

I would take a piece of very fine polish and polish the shit outta them before I bought new ones for that much if you want to keep abs.
 
1 - 15 of 15 Posts
Top