GMC Truck Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,004 Posts
Discussion Starter #1
Hey guys, so this morning I leaned my MAF and TB and the truck runs differently now. First off it wouldnt fire up right away on the initial start up, but after I turned it over it fired. The idle was a little choppy at first then I turned the ac and it idled higher than it went back down. It is idling at like 650 rpms from right now. Also it is downshifting different when I am slowing down and coming to a stop. No codes are being thrown. I think I might have moved the butterfly valve a tad bit, but idk if that is the cause and needs to recalibrate itself or its just everything is clean so it runs differently.
 

·
Premium Member
Joined
·
6,277 Posts
its gotta learn how to idle and run again....just drive it
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #4
Yeah I just went and drove it around. All fixed
 

·
Premium Member
Joined
·
6,277 Posts
i think the offical procedure is to let it idle in park for idk how long, then let it idle in gear for X minutes too....ive always just driven it around for a day or two and its back to normal. glad its up and running again
 

·
Registered
Joined
·
1,004 Posts
Discussion Starter #6
Thanks man. I just drove it awhile on the highway for a little while. Dont want to damage the transmission or torque converter driving around on the street especially when your truck is trying to go when your stopped at a stoplight. What was funny was at 35 to 40 mph it had cruise control because the throttle was opened for a bit lol
 

·
Registered
Joined
·
154 Posts
Same thing happened to my buddies NNBS. It was actually idling so high that it would shift from 1-2 with no throttle input. Like you guys said we just drove it around on the highway for a while and everything got back to normal.
 
1 - 7 of 7 Posts
Top