GMC Truck Forum banner

1 - 12 of 12 Posts

·
Pimpin' ain't easy
Joined
·
49 Posts
Discussion Starter #1
04 silverado lt pkg with the digital dual zone climate control. anywho the question when it seems to be over 75ish outside ambient temp my display will be blank and inop, however when it cools off in the evening or first thing in the morning it works fine as it should, is the unit itself bad?

TIA
 

·
Registered
Joined
·
129 Posts
04 silverado lt pkg with the digital dual zone climate control. anywho the question when it seems to be over 75ish outside ambient temp my display will be blank and inop, however when it cools off in the evening or first thing in the morning it works fine as it should, is the unit itself bad?

TIA

There are 2 types of ambient temp sensors one for Outside Air (Ice Warring) blah blah and inside ambient temp sensors I would think there are two sensors inside one for each side IDK not at work to look it up for you....
 

·
Pimpin' ain't easy
Joined
·
49 Posts
Discussion Starter #4
sorry guess i might have noobed that op up lol. but maybe the temp sensors have something to do with it lol. when my truck has been sitting at work and its warm out the digital display for my climate control is not coming on whatsoever, example last night on my way home from work i could not use my ac or vent or anything due to the unit not being "on" i guerss would be the right word, i came home parked it did nothing to it overnight, this morning works fine. i really dotn wanna plug a dealership with money right now over this and was hoping someone has had this issue or maybe a tech.
 

·
Pimpin' ain't easy
Joined
·
49 Posts
Discussion Starter #7
ive seen cheap ones on ebay and at my local yard but i dont want to throw a part at something im not sure is broke
 

·
Registered
Joined
·
3,481 Posts
maybee the head is bad. I would try and check the connections in the rear first. Your problem is heat related. Remember, when things heat up they expand, contract when cold. You may have a bad connection that breaks in the expansion, and connects when cold.


Mr. 960
 

·
Pimpin' ain't easy
Joined
·
49 Posts
Discussion Starter #9
i see what your saying about expansion/contraction i just dont think the head is bad, i will pull the unit out and check the connector(s) though this week when i get a chance, its been cooler so its been workin fine for the last few days so .....
 

·
Registered
Joined
·
3,481 Posts
anyone know where the interior "temp" sensors are for the climate control?
One is the top dash piece that also controls the auto head lights. The other is the little tweeter looking thing above your head, and I think another one is under the dash somewhere. From what you describe, I don't thin the sensors would cause your display to go blank though.

Mr. 960
 

·
Pimpin' ain't easy
Joined
·
49 Posts
Discussion Starter #12
i dont think so either just thought id check the connections at em just in case, i was loooking at someone on ebay selling em that refurbs your current one and he claims they have problems with em anyway that he will address, aside from the lights on em goin in/out which i already deal with lol
 
1 - 12 of 12 Posts
Top