GMC Truck Forum banner

1 - 8 of 8 Posts

·
Maroon,Black,Chrome
Joined
·
3,347 Posts
Discussion Starter · #1 ·
My truck has been in storage since the beginning of may. After about 6-8 weeks I went and started it up and let it run for 15 min. It started right up without issue and ran fine. it made allot of noise at first, but after 15 seconds it was normal. 2 weeks later I had to get it out of the garage for an inspection and after I pulled it down the driveway and parked it in the street I was walking up the driveway and about half way up the driveway I smelled coolant but didn't see anything and didn't smell any in the garage. When I got back to the truck I checked under the hood and didn't smell/see anything. I put it back in the garage for a week and didn't have any issues the following week.

I've had issues in the past with the coolant light coming on every 12-15K miles.


On another note, if the truck sits for a while, when I start it up for the first time it makes a knocking noise for the first 10-15 seconds. It doesn't do it if it only sits for a day or so. I assume that all the oil has left the bearings, but is there anyway (additive?) to stop this?
 

·
Registered
Joined
·
346 Posts
Could try that lucas oil stabilizer stuff
 

·
Premium Member
Joined
·
6,277 Posts
probably lifters
 

·
Registered
Joined
·
150 Posts
Yea probably the lifters. Put some Lucas Oil Stabilizer in. But remember to drain out the exact amount of oil you going to put in tho.
 

·
Maroon,Black,Chrome
Joined
·
3,347 Posts
Discussion Starter · #5 ·
Ill try the stabilizer, I was kind of thinking about it, but wasn't sure.
 

·
Maroon,Black,Chrome
Joined
·
3,347 Posts
Discussion Starter · #6 ·
Any idea on the coolant smell? Someone previously suggested the head might be cracked, but I don't know if it would make its way into the combustion chamber and if it did, would I smell it after combustion.
 

·
HABS SUCK!!
Joined
·
1,833 Posts
intake gasket leak?
 
1 - 8 of 8 Posts
Top