GMC Truck Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
807 Posts
Discussion Starter #1
ok, when i start my truck for the fist time in a day(morning, afternoon, etc.) it seems to not start for 2-5 seconds while i hold the key. but if i turn the key on...hear the fuel pump turn on, then turn the key off, on, off, etc 5 times or so then start it...it will start right as the key turns.
also, at idle the truck runs good but seems to skip. skip as in like kind of cut out a little and everytime it "skips" you can hear a tick noise comming from the coil packs, and im guessing the tick is a spark problem but i have new plugs and wires.

things that may help
-truck sat for a month and a half without being started before doing this.
-shortly after i started driving it again(like a week after) the fuel pump made a loud wining noise for a whole day but just that day then stopped.
-also the truck doesnt skip while driving as it does at idle.

anybody have any ideas please let me know i sprayed water on the coil packs as a buddy told me you would see a spark come off of it if there was a spark problem but no spark. -thanks rob:shake:.
 

·
To hell with BHO!!
Joined
·
2,645 Posts
Pull off the vacuum line on top of the fuel pressure reg. See if fuel comes out of it. Its pretty common they fail. Lets single that out first as far as your fuel issue.
 

·
Swamper Brotherhood
Joined
·
3,894 Posts
you could also go ahead and change your fuel filter for an start, it could be a number of things if it surges at idle
 

·
Registered
Joined
·
807 Posts
Discussion Starter #4
fuel filter was changed a month ago...and as for pulling the vacuum line off the fuel pressure reg. a buddy of mine tested the pressure for me he said he opened up a bleeder on the fuel rail and said i have plenty of pressure. also remember this is ONLY the first start of the day. i could start it at 5am drive it for a little go home and sit till 5 at night and it would start fine the second time.
 

·
Left Jizz
Joined
·
1,225 Posts
you could have a leak and air is bleeding into the system, letting the fuel leak back into the tank. I don't know if this is possible with the vortec's, but my buddies cherokee does this, or at least this is what the shop told us. He just lives with it.
 

·
Masshole
Joined
·
5,276 Posts
yeah mine does that too. I was told it could be a common fuel valve in the pump? i was thinking just my filter because i have 36K miles on mine, but normally it would do it when driving too, and not just sitting over night when u go to start it in the morning.
 

·
To hell with BHO!!
Joined
·
2,645 Posts
Pump has a drain-back valve..

You could have sufficient pressure, sure. But the reg could still be leaking fuel up the vac line into the intake!

Cook,

Have fun changing your filter. It lives in the tank.
 

·
Masshole
Joined
·
5,276 Posts
....if u look at my drivers side mirror...move right about 5 inches, and go straight down underneath my truck on the inside of the frame, there is where my fuel filter lives....but its solid in there, and when i try to take it off...it feels like im going to strip it, even with a 5/8 flare wrench. so i might have someone do it at my work for me
 

·
Registered
Joined
·
248 Posts
I am having a similar problem with my first start of the day. Mine will try to start up and stumbles and dies but fires right up the second crank and therest of the day as long as it don't sit for an extended period of time and I have checked everythin and we have come to th conclusi9on that mybe my intake manifold is warped and creating a vacuum leak but after it heats up since its plastic it molds back into place. So I am changing that out next week to see if that helps a chevy guy mentioned he has seen that a few times.
 

·
Registered
Joined
·
807 Posts
Discussion Starter #10
Pump has a drain-back valve..

You could have sufficient pressure, sure. But the reg could still be leaking fuel up the vac line into the intake!
jared, how could i check this? it only does it at idle and i hear a spark noise when it skipps, it even does it a red lights, stop signs, etc. when im stopped. but in motion its fine cruise control it doesnt skip at all just a constant non-skipping exhaust note...
 
1 - 12 of 12 Posts
Top