GMC Truck Forum banner

1 - 18 of 18 Posts

·
5.5MPG!!!!!!!All Day Long
Joined
·
123 Posts
Discussion Starter #1
ok....here's the deal. alot of u know my abt my throttle response problem and have witnessed it. i dont know how many other mechanics there r on here and i have 15 years experience myself. so here's my ?. has anyone ever heard of the stator in ur torque converter freewheeling and causing lack of acceleration. lemmee explain...... when u floor the truck in park it just gradually revs up. in gera it is quicker to half throttle it than to full throttle it cause it revs very slow when u full throttle it. make sense?. now i've heard of torque converters freewheelin insid ethe converter, but that wouldnt cause this problem i dont think. has anyone ever heard of this? it is drive by wire and has had the tac module replaced....the pedal assembly replaced and the acceleration module replaced so far. personally, me and my boss and another buddy of mine that owns a shop think it is in the pcm somewhere. anybody?
 

·
[>
Joined
·
3,255 Posts
Didnt you get a Nelson Tune? Maby call him to see what he thinks. Maby get a "stock" one back and see if it fixes it?

Just an idea.
 

·
a.k.a. turbodan
Joined
·
3,220 Posts
it revs slowly when its just idling in the driveway? maybe try to manually rev it up on the throttlebody(dont know if you can do this on fly by wire) I have heard of the stator spinning in the case, but its usually got one(or more) of the rollers or springs out of it, or is cracked to cause the slippage. If you can see your TQ good from the inspection cover, i would try to see if it has balooned up or is discolored in any way.
how many miles on the truck? what rear end gears do you have? is the tranny feel like its slipping as well? I cant really see the stator blowing apart and you not hearing anything from the tranny, if its spinning, you would probably hear the screaching of it and have burnt tranny fluid(did u check the fluid?what does it look and smell like?) but if the stator came apart you probably could hear the little rollers making noise in the TQ

Just a few ideas that i can think of now? Im going to get some of my books from school and see if i cant dig up anything else.

Dan
 

·
5.5MPG!!!!!!!All Day Long
Joined
·
123 Posts
Discussion Starter #4
yes.....got the nelson tune, but is back to stock for now. tranny fluid looks and smells good. 35k on the truck 4.56 rear gears....allison tranny. does not slip and u cant manually throttle it due to no cable. its electric motor which opens immediately upon acceleration. have watched it while someone pushes pedal.
 

·
Line-X of San Antonio
Joined
·
5,237 Posts
hrmm... you have a 2002. i have heard of problems with the allison, but only while towing heavy loads. i thought they had the bugs worked out by 2002 though. have you read the codes in the tranny computer? the allison has its own comp right? hope you get it figured out mark!
 

·
5.5MPG!!!!!!!All Day Long
Joined
·
123 Posts
Discussion Starter #6
Josh said:
hrmm... you have a 2002. i have heard of problems with the allison, but only while towing heavy loads. i thought they had the bugs worked out by 2002 though. have you read the codes in the tranny computer? the allison has its own comp right? hope you get it figured out mark![/QUOT

no codes in the tranny comp......and yes.....it is the allison and it does have its own comp. i should be getting it back today or at least going to see if prob was corrected. personally, i think it is a pcm problem. they wont listen to me tho.
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
:LOL: What he didnt tell ya is hes having to drive a FORD while his is in the shop
 

·
5.5MPG!!!!!!!All Day Long
Joined
·
123 Posts
Discussion Starter #10
damn....stephen......u suck....................that was a secret.........i'm all embarrassed. at least its an 04 crew cab


now they r putting a torque converter in it. i dont understand the logic behind that but hey......its their dime
 

·
a.k.a. turbodan
Joined
·
3,220 Posts
I read through my books all night(fell asleep in them actually...lol) and cant find any reasoning for the problem to be a torque converter. It doesnt make sense for the engine to rev up slowly when in neutral. if it was only in gear i could see the TQ being a problem, but not in neutral.

does it seem almost like the truck retarded timing? is it running too rich or lean? how does the truck idle, smooth or choppy or is there any hesitation when you just goose it idling?
Its hard to try to think of something without seeing the truck in front of me.

Ill keep thinking,
Dan
 

·
Line-X of San Antonio
Joined
·
5,237 Posts
damn mark. id tell them to stick your truck up theyre ass, and give you that duramax youve been wanting.:head:
 

·
internet bigot®
Joined
·
4,016 Posts
i might be coming in kinda late on this... but stators dont move... stator = static.... the turbine in it moves...
 

·
5.5MPG!!!!!!!All Day Long
Joined
·
123 Posts
Discussion Starter #14
fullthrottledan said:
I read through my books all night(fell asleep in them actually...lol) and cant find any reasoning for the problem to be a torque converter. It doesnt make sense for the engine to rev up slowly when in neutral. if it was only in gear i could see the TQ being a problem, but not in neutral.

does it seem almost like the truck retarded timing? is it running too rich or lean? how does the truck idle, smooth or choppy or is there any hesitation when you just goose it idling?
Its hard to try to think of something without seeing the truck in front of me.

Ill keep thinking,
Dan
the truck runs fine. it is a lil sluggish, but not bad and i'm figuring it has to do with the problem tho. i really think it is the pcm.but when i hook it up to the genisys, everything looks good. spark advance is right on, no misfires, and i and my boss and my frerinds with their own shops also agree. they tried to tell me my plugs and o2 sensors were silicone contaminated........... i told them to install them for me and if it fixed the problem, then i would pay for it....if not, i wouldnt.............ok......just got a call from the dealer as i am typing. he says come get it.....this is the way it is supposed to act and that every obne they have tested does the same
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
the way its suposed to act? Tell them to eat shit and die, it didnt used to act that way.
 

·
Drive It Like Ya Stole It
Joined
·
6,656 Posts
Angry Samoan said:
You need to get rid of that gas guzzlin' Brick and get a D-Max! :read:
Who wouldnt love a D-max! I hope to have one someday. BTW John what kind of MPG do you get in yours with 38s. What rear gears do you have?



I PMed TB for ya Mark if you can read this.
 

·
Line-X of San Antonio
Joined
·
5,237 Posts
Angry Samoan said:
You need to get rid of that gas guzzlin' Brick and get a D-Max! :read:
holy shit, welcome back from the dead john :head:
 
1 - 18 of 18 Posts
Top