GMC Truck Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,828 Posts
Discussion Starter #1
Not big into car audio at all (mainly stay in the offroad forum). Need some help I have A 02 GMC HD . Few weeks ago my cd player (kenwood KDC MP5028) shut off. Thought nothing of it unlugged it, plugged back in worked fine. Then it starting doin it every few days now its everyday. Thing worked fine it will stay turned on as long as its not playing music but as soon as music starts it shuts off.

Now to troubleshoot i have another kenwood deck that uses the same harness ( I know not much troubleshooting if its the wiring) to see if it was my deck that had the biscuit. It comes up "Protect" and is pretty much locked out. Dont have a factory radio to check it with and all the fuses apear to be fine. Let me know if its something simple i am over looking. I tugged on the all the wires and all appear to be tight.
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
you have a bad speaker or bad wiring leading to a speaker. The deck thats in protect can be pulled out if you reset it. Easiest way to tell, you usually hear a "pop" or "crackle" from the offending speaker right as the deck comes on or turns off
 

·
Registered
Joined
·
1,828 Posts
Discussion Starter #3
I did hear a crackle when i turned it on. Been wheelin the truck so a loose wire is possible ill check it out in the morning but i think you prob nailed it man thanks.
 

·
Premium Member
Joined
·
7,892 Posts
you have a bad speaker or bad wiring leading to a speaker. The deck thats in protect can be pulled out if you reset it. Easiest way to tell, you usually hear a "pop" or "crackle" from the offending speaker right as the deck comes on or turns off
Agreed. Pretty sure that will solve it. You can always figure out which is the offending speaker by disconnecting/reconnecting them 1 by 1.
 
1 - 5 of 5 Posts
Top