GMC Truck Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
hey guys, wondering if someone here could give me some advice. ive got an 04 silverado with a 5.3 running 113k miles. somehow or another recently i started hearing a "ping" or detonation under load. under load meaning either really gettin on it and or moderately heavy acceleration. with this noise when im really gettin on it, im seeing alot more exhaust in my mirror. not white or anything but normal exhaust look, just alot of it that i never noticed before. truck feels sluggish around town driving, but when ya get on it, it still moves nice...just pings like crazy, so i dont run it hard anymore. also its gettin a little bit of rough idle. not horrible but not smooth, i could be just nit pickin now, since ive noticed the ping. a couple weeks ago i ran seafoam through it with no results, but since then when the cruise is on and im goin down hill, the truck surges to keep at set speed. ive owned the truck since 80k miles and has never had any ses light come on. im baffled, can anyone PLEASE help me pinpoint this issue?! thanks for any input
 

·
JUGS Racing
Joined
·
1,199 Posts
Try running a can of seafoam through it.
 

·
TTG shawty
Joined
·
3,101 Posts
change your spark plugs. if you go with iridium plugs keep the gap at .040
 

·
GMFS Military Member
Joined
·
207 Posts
change your spark plugs. if you go with iridium plugs keep the gap at .040
Fuck wasting money on iridiums...shit is just hype. Stick with AC Delcos. Your 5.3 and wallet will thank you.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #7
I've already tried seafoam if anything it made it worse. It's gettin plugs and wires this weekend and prob goin with deco cause I have a hookup. A bad pack would cause a miss and throw a code wouldn't it? My ol man swears up and down it's a blown intake
 

·
just a senior...
Joined
·
965 Posts
Fuck wasting money on iridiums...shit is just hype. Stick with AC Delcos. Your 5.3 and wallet will thank you.
ppsstt, stock was iridium. If they last 100,000 miles...really a waste??


OEM plug AC Delco Iridium 41-985 ( .040" gap) like $6.50 each...
 

·
GMFS Military Member
Joined
·
207 Posts
Possibly too much spark advance (even though its computer controlled). Could be a bad coil like your thinking or even a intermittent knock sensor. If the KS is bad or is working intermittently, the diagnostic system will test it, find it bad, and lean out the timing. Check for other things like possibly a small vacuum leak?? Kind of grabbing at straws in the dark here since i deal with my 1990 350 small block... Hope this helps!
 

·
GMFS Military Member
Joined
·
207 Posts
ppsstt, stock was iridium. If they last 100,000 miles...really a waste??


OEM plug AC Delco Iridium 41-985 ( .040" gap) like $6.50 each...
Sorry I was under the impression that we were talking about the super badass XXL "fly me to the fucking moon" sparkplugs. LOL :crazy:

[ame]http://www.amazon.com/Denso-IRL01-27-Iridium-Racing-Spark/dp/B000M6SSNS[/ame]
36 Bucks a pop...Fucking tards << Prolly need the expensive high-powered plug for burning all that rice in the RX-8's LOL:jester:

If were talking about Delcos then touche` sir and i fully agree :shake:
To the OP>>Try a full tune up and see what changes.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #11
Yea I'm goin to look at the vacuum lines, I may just go ahead and change the knock sensors, atleast the problem prone rear one and see what that does. I don't care what I haveta do to fix this, I miss my power
 
1 - 11 of 11 Posts
Top