GMC Truck Forum banner

Engine Fires But Wont Stay Running...Please Help!!!

9598 14
I’m finally ready for to fire up my motor and I cant get it to start. I’ve got a 2001 4.8 truck engine. It has an LS1 intake manifold, 28.8 ls1 injectors, ls1 fuel rail returnless style, MSD fuel pump, Professional Products Fuel Pressure Regulator, Removed EVAP system, Removed EGR, Shorty Headers, 220/222 110 LSA cam, SLP ti springs.

Anyways I’ve tried to get the motor to fire and it fires right up but immediately dies like the computer is shutting it down. Do you think this is a tuning issue at this point? I do believe I have everything hooked up but I could have missed something. Please help!!!
1 - 15 of 15 Posts

·
HOT AIR BALLOON OWNER
Joined
·
47,427 Posts
Crank relearn?

And that combo, is that seriously your setup?
 

·
HOT AIR BALLOON OWNER
Joined
·
47,427 Posts
x2, VATS issue. :imo


Yeah, I seemed to remember I had that issue when I reactivated VATS once another tuner turned it off for me. LOL... not by request. :nono:

I can't recall what I did, probably involved hand clapping, touching my toe to my nose, and something along the lines of the hokey-pokey.
 

·
AllOffTopic.com FTW!
Joined
·
25,224 Posts
Thats the security relearn. I dont think that will fix the VATS issue.
What do you think VATS is? It's the security stuff that kills the engine immediately after starting if it thinks your key isn't in.

Actually, I doubt that truck has VATS (aka Passkey II), which is the one that has the visible resistor in the key. My 1997 Pontiac and 2002 GMC both had Passlock II, which has a normal key and keeps the resistor in the key cylinder.

Passlock II presents the exact symptom described, it fires then dies immediately.

http://www.the12volt.com/installbay/forum_posts.asp~TID~100917~PN~1

Unless I misunderstand the term "security relearn"...
 

·
Registered
Joined
·
1,424 Posts
Discussion Starter · #11 ·
ITS ALIVE!!! i was finishing up drilling and tapping the clamps to the frame to hold the fuel lines and hit the exhaust pipe with the tap handle and saw a spark. I thought hmm maybe i should check the ground to the engine. Bingo! i only had the ground on the back of the block finger tight. I tightened it down and she fired right up. I had to give it some gas for a few seconds to get her to idle but she ran for a few. Now i just need to hook up my fan and i can start to break in the cam. I'm so excited right now!
 

·
Registered
Joined
·
7,055 Posts
What do you think VATS is? It's the security stuff that kills the engine immediately after starting if it thinks your key isn't in.

Actually, I doubt that truck has VATS (aka Passkey II), which is the one that has the visible resistor in the key. My 1997 Pontiac and 2002 GMC both had Passlock II, which has a normal key and keeps the resistor in the key cylinder.

Passlock II presents the exact symptom described, it fires then dies immediately.

http://www.the12volt.com/installbay/forum_posts.asp~TID~100917~PN~1

Unless I misunderstand the term "security relearn"...
i had this shit happen to me once. my friend had it happen quite a few times on his tahoe. i ended up taking apart my dash and unplugging the big guage wiring harness for my remote start and plugging it back in. no idea what it did but after trying everything she started up right after i did that. hasn't done it since
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top