GMC Truck Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all my fellow chevy lovers!!! I have a 2009 2500 6.0 vortec and I need answers to my issues. It has the common delayed start when hot. It's fires the first time every time unless it has already started that day. I drive to my shop maybe 20 miles turn it off 2hrs later turn the key over the engine can run the battery out and never fire. Turn key off then start again engine fires on first rotation. I had codes read and only show lean bank 1 and 2. The problem started while truck was bone stock. Since I have put a cold air intake, new throttle position sensor and gaskets, new plugs witch were all white coated by the way,, and yesterday replaced my cracked manifold with a new set of speed engineering stainless headders with the turbo tube clamps to solve the forever 6.0 exaust leak. What part do I need to change to solve the lean bank 1 and 2 and my delayed start issue?? I know the root of both problems is 1 part. I have had 5 z-71 and 1 Yukon Denali and replaced the fuel pump one every 1 through my experience they either work or they don't I have never had 1 that half-assed worked causing low fuel pressure at the engine. Any enlightenment would be greatly appreciated
 

·
Registered
Joined
·
2,538 Posts
I think the best bet is find a local LS tuner and get a lab top tune. Not a helpful answer, but it needs a tune to take advantage of the mods, and they’ll tell you exactly what’s cause if the problems.

Could just have a handheld still loaded in the PCM messing it up. Also had this happen on my 2013 2500hd, always blew relays. Some one spiliced trailer wiring into the Fuel pump control module.
 
1 - 2 of 2 Posts
Top