GMC Truck Forum banner

1 - 20 of 24 Posts

·
a.k.a. turbodan
Joined
·
3,220 Posts
Discussion Starter #1
went to the track tonight for a good time with Ben (1TRUESS). i really didnt get too good of times worth posting(lol) but we had fun and i snapped a few pics.






here is me workin on my broken ass truck... fuck..
 

·
I am the Moderatonator!
Joined
·
1,128 Posts
Nice pics Dan. It sucks about your rear end getting damaged. But now you actually have a valid reason to get the 4.10's in there. Once the 4-link and 'verter get put in, its ganna be a rocket out of the hole.:head:
 

·
Registered
Joined
·
1,035 Posts
The pics turned out good! To bad there are no pics of us running together. I think I am going to call Allen and get a custom tune this week. I don't know what my truck's problem is, but is sucks that I just got a TT3000 converter and slicks, just to run .5 slower then it should!? WTF!!
 

·
a.k.a. turbodan
Joined
·
3,220 Posts
Discussion Starter #6
my truck was allready broke, just made it worse.. besides its only a cracked axle tube anyways!!!
 

·
Zombie Squad
Joined
·
1,244 Posts
maybe its because u forgot to put ur headlight in :read:
lol jp, ive seen that done before but what exactly does it do?
 

·
THE VIKING !!!
Joined
·
279 Posts
So what did they run ???
 

·
It's Jerry's World
Joined
·
3,573 Posts
AftermatH said:
maybe its because u forgot to put ur headlight in :read:
lol jp, ive seen that done before but what exactly does it do?

his air filter is right behind the headlight, so taking it out lets it get more air, giving it a ram air effect, which is about .1psi.
 

·
Registered
Joined
·
1,035 Posts
OrangeCrush said:
cool pics dan, why do you run with the 20s on it?? that gotta be killin your times.
We both were running 27 inch slicks!
AftermatH said:
maybe its because u forgot to put ur headlight in :read:
lol jp, ive seen that done before but what exactly does it do?
It opens up a big hole directly to my cold air intake!
SierraSport said:
So what did they run ???
I ran a very disappointing 14.6 @ 91mph with 2.2 60' times. It sucked because I should be run 14.0 with 1.9 60' times. Last year I was running 14.5s @ 94mph 2.1 60' with 29 inch stock tires, and this year I have a TT3000, billet servos and 27 inch MT ETs. Something in wrong!?!
 

·
a.k.a. turbodan
Joined
·
3,220 Posts
Discussion Starter #15
pewter00, hood is in the garage being sanded and repainted. i had a few fitment problems that needed to be changed.

I cant run my stock rims on the front over the drop spindles. i need at least a 17" rim. soon i am changing around my drop so i can put my stock spindles back on, and just have lca's

oh yeah, i ran a 14.94, which was .01 faster than before. i was still spiining with the slicks and the crosswind, and shitty traction, bad plugs.. and i cant think of any more excuses right now!!!! lol. just need to spend more money and get this turbo spoolin!
 
1 - 20 of 24 Posts
Top