GMC Truck Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
i was having problems with my gas gauge and truck starting in general (i would have to bang on the gas tank to get her started some mornings) so i went ahead and changed the entire fuel pump assembly. everything was good but then a day after the repair the gas gauge shot to E. whenever i start the truck the gauge goes all the way up to F and then back to E no matter how much gas there is. recently the gauge has made it to like the halfway mark before going back to E. with the key off and after sitting for a little while ill get like 1/8 tank reading before starting the truck. any input would be greatly appreciated. thank you
 

·
Registered
Joined
·
900 Posts
I had to replace my fuel pump. I forget What the name of the part is on it that the gauge reads from but you have to buy the pump
 

·
Registered
Joined
·
1,684 Posts
well this is what i know. mine in my old one stopped working till i changed the pump, the contacts on the float broke off so it was a open circuit. it always read full. now with yours always going to empty im thinking the harness is wired wrong as it isn't getting any resistance from the float for the gauge.
 

·
Registered
Joined
·
19 Posts
Did the pump come with a connector to rewire the pump have seen them not pinned right and cause the pump to run backwards or the gauge to read backwards


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
307 Posts
if its just the gauge at the cluster you can replace it or have it replaced. Check out USSpeedo if that is your problem. i had my entire cluster go out so i got a replacement for a reasonable price.
 

·
Registered
Joined
·
900 Posts
Just remembered What mine was. It was the sending unit was bad. The pump and the sending unit are together. The sending unit in those are cooled by fuel splashing up so when you run them on low fuel a lot they burn up but yours may be something else since y'all keep talking bout wiring
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
even bigger problem now. the truck wont start some days. i got a fuel pressure tester. its only getting like 44 psi. i ordered a fuel filter and ill go from there i guess. the fuel gauge is the least of my worries i guess
 

·
Registered
Joined
·
1,684 Posts
Definitely the pump gone out
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
truck has been starting ever since i tightened the battery terminals and actually replaced the bolts on them because the old ones have been stripped since i bought the truck. still need to do another pressure test to see if maybe the bad current would cause the fuel pressure to be low. but the gas gauge still does not work so that is my main concern until i have a problem starting the truck again
 

·
Registered
Joined
·
900 Posts
Like I said replace the fuel pump. The sending unit has.gone bad and it's in with the fuel pump so you need a fuel pump I'm almost 100% certain
 
1 - 13 of 13 Posts
Top