GMC Truck Forum banner

161 - 180 of 204 Posts

·
.
Joined
·
502 Posts
My 2006 has always clunked randomly when letting off the brake at a green light. Recently it has developed a metallic "ting" sound like a screwdriver hitting the driveshaft tube.
 

·
Registered
Joined
·
519 Posts
We have a classic 07 2500hd ECSB 4x4 6.0L that has a slight vibration at any speed over 45mph. We have taken the stock steel wheels off and tried alluminum, new rotors all around, new front wheel bearings, new shocks, all new u joints, and had the t case pump rub repaired. Been fighting this since ~120K miles and currently has 196K.

The dealer is now saying its the yoke. Yes it has yoke clunk but with as many times as its been in the shop and had it taken off you would think they would have thought of that one earlier.

Any ideas?
 

·
Registered
Joined
·
156 Posts
I'm glad to see others with this issue, I recently purchased a 2012 and noticed this the fourth time that I drove it. After reading this I picked up a set of spring clamps from Oreilly's: part number SPR 13-1401A and will be installing them tomorrow, hopefully I get the good results as others have. Will post back ASAP!
 

·
Registered
Joined
·
156 Posts
Two days of driving and no more "clunk". Thanks again, everyone!
 

·
Registered
Joined
·
546 Posts
Quick question as far as adding the leaf spring clamps. Mine chirps and clunks real bad so I was going to try this. But I have the rcx 6" lift with the blocks in the rear. the rear blocks have the two big u-bolts and then two small u-bolts as well. Has anyone ever added this mod to this setup?
 

·
Registered
Joined
·
62 Posts
Another fix using the spring clamps. It actually feels better off the line now. Started freaking out when I heard the noise, and stumbled upon this sticky. Glad it worked and was cheap.
 

·
Registered
Joined
·
1,035 Posts
Running them on my CC 2/2 drop for over three months now. Fixed the problem for me too!
 

·
Registered
Joined
·
159 Posts
...been running them for a long time now. the truck is still feeling solid & clunk-free, like the day I installed them. If your problem comes back, it could be something else, maybe a u-joint??
 

·
The Canadian
Joined
·
3,242 Posts
So when putting on the clamp fix, are you guys adding any shims/spacers/bushings or anything between the leafs? Or just simply putting the plate & 1 clamp around the leaf packs 6" forward of the rear axle? is 6" a good #, or farther forward?
 

·
Registered
Joined
·
159 Posts
So when putting on the clamp fix, are you guys adding any shims/spacers/bushings or anything between the leafs? Or just simply putting the plate & 1 clamp around the leaf packs 6" forward of the rear axle? is 6" a good #, or farther forward?
Some have used shim/spacers/etc, but most(incl me) just simply use the clamp, about 6" forward of the rear....
 

·
The Canadian
Joined
·
3,242 Posts
Some have used shim/spacers/etc, but most(incl me) just simply use the clamp, about 6" forward of the rear....
okay thanks. Getting my supplies to do this tomorrow
 

·
Registered
Joined
·
546 Posts
So the small u bolt kit did not solve my clunk.

Can somebody that has replaced yoke with nickel plated one post a link to where the purchased it please?

Thanks
 

·
Registered
Joined
·
9 Posts
This solved my problem too! Can't believe how long I went just accepting this noise as normal. The truck has a much more solid feeling now.
 
161 - 180 of 204 Posts
Top