GMC Truck Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
Hey gents. I was wondering if someone could point me in the right direction. My AC blows cold, but on the highest setting it hardly blows at all. My kids sweat in the back seat because the air doesn't make it back. The passenger hardly blows at all, on setting 5, it blows at maybe most cars level 2-3.

Any thoughts? Need to fix ASAP. Thanks
 

·
Registered
Joined
·
1,684 Posts
dose the fans seem like it spins a lot? sounds like the fan motor is going out or maybe some ac duct flap is not opening all the way.
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
No, it seems like I put it on setting 5 and it only actually goes to 2-3. No odd noises

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
3,481 Posts
have you checked your cabin air filter? May be plugged restricting air flow. Also can you hear the fan spin at faster RPMs once you put it to 5? If not, then the resistor pack down at the bottom of the HVAC plenum behind beauty cover on plenum may be bad. Note, that beauty cover needs to be removed to replace the cabin air filter also.

Mr. 960
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #7 ·
have you checked your cabin air filter? May be plugged restricting air flow. Also can you hear the fan spin at faster RPMs once you put it to 5? If not, then the resistor pack down at the bottom of the HVAC plenum behind beauty cover on plenum may be bad. Note, that beauty cover needs to be removed to replace the cabin air filter also.

Mr. 960
No sir, I have not checked that. I will tomorrow. yes, the AC does blow faster at 5 VS lower levels. setting 1 has almost no air stream at all. it's almost as if the know was pulled off and set back two positions (obviously not the case)

what else can I check/do? My poor boys sweat all day sitting in the back of my truck. really a crummy feeling

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
154 Posts
Not sure what else you can do but in the threads posted previously folks report after they change their filter that t blows harder on 2 than it did on 5 previously.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #9 ·
Not sure what else you can do but in the threads posted previously folks report after they change their filter that t blows harder on 2 than it did on 5 previously.


Sent from my iPhone using Tapatalk
thank you, I'll pull that cover off today and check it. I'll report back

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #10 ·
Well, not sure if it's a 100% fix, but it's definitely blowing a little harder, especially out of the passenger vents. Now it feels better, but like setting 5 is actually blowing at a 4 if that makes sense. Check these gross things out. So sick!


Should have been the first thing I did when I bought the truck

Sent from my SM-G900V using Tapatalk
 

·
Registered
Joined
·
34 Posts
Discussion Starter · #11 ·
WOW!!! I stand corrected. The filters fixed the problem 100%! I actually had to turn the AC down a notch on a 25 minute drive yesterday at 103* Temps outside, which I've NEVER even considered doing before because it was so inefficient. So happy it was a cheap and easy fix

Sent from my SM-G900V using Tapatalk
 

·
Premium Member
Joined
·
6,277 Posts
easy fixes ftw :pepper:
 
1 - 12 of 12 Posts
Top