GMC Truck Forum banner

1 - 11 of 11 Posts

·
Stars and bars aficionado
Joined
·
35 Posts
Discussion Starter #1
I'm still here just wanted a fresh start..anyway I have a few questions about my four wheel drive and need some real answers, no bullshit. When I put it in 4h or 4l I hear it lock in. I can drive fine a few feet forward or in reverse, but when I push the accelerator and take off either way, straight, turning, forward, or backward, it kinda pops and grinds like it's binding up. I'm thinking several things could be wrong: actuator not fully engaging, or the pinion bearing, or maybe my chain is jumping teeth? I'm thinking when they bottomed the truck out on the driver side on a boulder it may have messed something up.they hit something hard and had to replace the windshield and hood and the front end was screwed up real bad. We completely replaced the front end and greased everything and changes the transfer case fluid which was black and everything was dry. I know being dry is bad for em so do y'all think I have to tear the Differential apart and rebuild or can the bearings/chain/actuator be replaced and do I have to drop the transfer case to do these repairs? -thanks yall
 

·
Some dude on the internet
Joined
·
315 Posts
When you say the whole front end was replaced, was the front diff replaced also?
 

·
x3 shitbox owner
Joined
·
3,611 Posts
.


Sent from my iPhone using Tapatalk
 

·
Stars and bars aficionado
Joined
·
35 Posts
Discussion Starter #4
No just the steering and suspension cuz it was pretty much undrivable it would sway left to right every couple of mins, so we just replaced it all -pitman arm, idler arm, sway bar bushings, tie rod ends, hubs, and lots more but just now getting to the four wheel drive stuff now that summer is here I want it working right so I can take my girls to the creek and play around in it
 

·
Stars and bars aficionado
Joined
·
35 Posts
Discussion Starter #5
I was just wanting thoughts on possible problems. I'm thinking the actuator isn't fully engaging, but was told it could be the pinion bearing(s) or chain stretched and jumping teeth in the transfer case. I don't wanna go on a wild goose chase trying to find the real problem especially when it involves spending money.
 

·
Stars and bars aficionado
Joined
·
35 Posts
Discussion Starter #6
I know my CV axles are good and I can hear it lock in when I push the button and it goes into four wheel drive cuz it gets tighter and it pulls me right up out of a hole but the noise makes me cringe so I won't use it unless necessary but I got a four wheel drive to have fun in and with it Makin noise and having me afraid I'm gonna tear it up it's not very fun, well yes it is but the added fun of goin off-road is missing lol
 

·
Some dude on the internet
Joined
·
315 Posts
Reason I asked is because sometimes without knowing, I've seen people put junkyard used front diffs in with a different gear ratio than the rear and that's no bueno. What about your tires, are they the same size all around? Asking all the stupid/simple questions first to eliminate them as issues. If all that checks out, sounds like you'll be needing to go into the Tcase to look.
 

·
Stars and bars aficionado
Joined
·
35 Posts
Discussion Starter #8
Reason I asked is because sometimes without knowing, I've seen people put junkyard used front diffs in with a different gear ratio than the rear and that's no bueno. What about your tires, are they the same size all around? Asking all the stupid/simple questions first to eliminate them as issues. If all that checks out, sounds like you'll be needing to go into the Tcase to look.
Yea they're stupid ass 24s-305/35r24 to be exact and I got a flat yesterday so I'm grounded til I either get some 20s which is what I want or order some new tires but I hate these wagon wheels. Anyway my husband thinks it's engaging but not locking in all the way he thinks the actuator is bad and I had another guy at the tire place tell me the same thing or my CV axles but we checked those they're good
 

·
Some dude on the internet
Joined
·
315 Posts
That is very possible.

What I'd do to eliminate as much as I can is put the truck on jack stands, engage 4hi or 4lo while it's in the air and let the wheels spin, and see if it still does it. If the sound goes away, you need to verify your front and rear gear ratios are the same. (You never know what a previous owner may have done). If it still does it, pull the front driveshaft off the transfer case and do it again. If it still does it yet, then it's in the transfer case/actuator.

Also pictures of the case, front diff, driveshafts, CV shafts, would be helpful.
 

·
Stars and bars aficionado
Joined
·
35 Posts
Discussion Starter #10
That is very possible.

What I'd do to eliminate as much as I can is put the truck on jack stands, engage 4hi or 4lo while it's in the air and let the wheels spin, and see if it still does it. If the sound goes away, you need to verify your front and rear gear ratios are the same. (You never know what a previous owner may have done). If it still does it, pull the front driveshaft off the transfer case and do it again. If it still does it yet, then it's in the transfer case/actuator.

Also pictures of the case, front diff, driveshafts, CV shafts, would be helpful.
Ok I have a few pics I didn't get everything tho I'll try to get some in a few mins. But I held the brake and put it in 4L and went in everse and drive and bothe ways it makes the noise almost immediately. In 4H i was able to get some rpm's up a little before it did it. And nothing in 2H. And I had my door open and it's coming from right under where I sit and has a sound like something has come loose and is in a bind, sounds metalish and it sounds like bing bing, bing bing bing. And also, when I'm in 2H and shift into drive or reverse and also take off from a still position such as sitting at a red light, I get kind of a clank noise from around the same area. It always does it but sometimes it's louder and sometimes just barely. I never thought nothin of it cuz as far as I can remember every truck I ever rode in did this so I thought it was normal. Guess not, and she shifts great but here and there kinda shifts hard but not too Very often and seems like it's usually in reverse.
 

·
x3 shitbox owner
Joined
·
3,611 Posts
Would you be able to take a video, upload it to YouTube, then post a link here? It would probably help someone solve whatever issue you’re having.


Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
Top