GMC Truck Forum banner

1 - 5 of 5 Posts

·
180k & still > 4.8 Rams
Joined
·
24 Posts
Discussion Starter #1
ok guys, ive been following this writeup:

http://www.gmfullsize.com/forum/showthread.php?t=1159&highlight=corvette+servo

i have the whole thing out. My apply piston (servo pin) is stuck in the inner housing. it says remove the snap ring at it shoudld come right out but it doesnt!!! it hits as though theres a ring on it but i cannot see ANYTHING holding it! i dont know what to do and im in a panic because i have to get back to school and my truck is at a friends house.

this is definitely not an easy install :(
 

·
resident pyromaniac
Joined
·
7,498 Posts
kevindepot said:
With that shit out of the way. You can now remove the inner housing and 2nd apply piston. Inside the 2nd apply piston is your 2nd apply cushion spring and spring retainer they are held in by a snap ring.
calm down dude. they're all the same. stressing over it wont allow you to properly function/think your way through this:imo now, are you sure you removed BOTH the e-clip and the snap ring?
 

·
GMFS slowest truck :read:
Joined
·
5,501 Posts
everyone ive messed with pops right out after you get the clips and shit out. sometimes takes a lil persuading, but they come.
 

·
180k & still > 4.8 Rams
Joined
·
24 Posts
Discussion Starter #4
well i got it out. had to beat it with a rubber mallot.

i got it installed but im really having a fun time now. 4th gear is gone. this is making me feel sick to my stomach because i have to drive 180 miles tonight and i cant take it back apart until i get home. any idea what could be wrong, i plan on driving it all the way home in 3rd... when gas is 3.60 a gallon :( :( :(
 

·
JetBlue
Joined
·
2,306 Posts
JoeliusZ28
180k & still > 4.8 Rams
Dodges run a 4.7L for their small V8....

-bZj
 
1 - 5 of 5 Posts
Top