GMC Truck Forum banner

1 - 20 of 23 Posts

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #1
ok, so its inspection time for me, and theres one thing i need for inspection...A HORN! and guess what? my "like a rock" horn crumbled or something. last year the low pitch went out. this year the high....I went to a dealer today to get new ones. I walked out of the dealer with no horns and shaking my head because one horn was 55 bucks and the other was like 49!!!!! :pow: wtf is that? i thought about getting some universal horns from o'rileys or something, but then i remembered chevy does the weird pos./pos. wiring thing so i dunno if universals would work cause theyre pos/negative. anyone have this problem or any wisdom?
 

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #2
air horn? i dunno if i wanna go that route....more stuff to break....and where am i gonna mount the darn thing lol....
 

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #4
ummmmm lol....im sure i can figure something out. what kind of air horn? just like the ones at o'rileys? how can i wire it so that my steering wheel honks it?

59929065.gif
 

·
Registered
Joined
·
2,525 Posts
ha ha ha, you city people and inspections...i laugh at you. I have nothing, no emissions, testing, anything...illinois only has 2 places that care about that stupid sh*t Chicago and St Louis as far as i know.
 

·
MIA
Joined
·
1,157 Posts
CrazyAggie05 said:
ummmmm lol....im sure i can figure something out. what kind of air horn? just like the ones at o'rileys? how can i wire it so that my steering wheel honks it?



An 18 Wheeler horn.

Mine is unplugged from the factory horn and tapped in there. Push the horn button and there ya go.

Man if I can fit 4 horns in my front bumper .. you will have no problem.
 

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #7
ok now that the picture works you see what i mean about mointing it in the bumper lol? not much there to cover it up...01GMC im not getting what your saying to do....
 

·
Bigger than you!
Joined
·
196 Posts
Mount it on your inner fenderwell just below the radiator reservoir and pull power from the wires that now plugs in to the factory horns.
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
I had air horns on my old Blazer, I helped the lady in front of me get her sticker cuz she didnt have a horn! Just wire the + of the stock horns to the + on the compressor for the aftermarket ones or get some universal ones from Pep Boys or whereever
 

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #13
ok i went to advanced autoparts and bought those air horns that come with the little compressor like im guessing you guys got. it has the relay and crap to wire it up with. i cant get this fuckin pos to work! theres two diagrams to tell you how to wire it up. one is for pos grounded and one for neg grounded. i tried both, i think. how the hell did yall get yalls to work? i can hear the trucks horn relay workin in the main junction box, so i know thats not the problem. ive been using the dark green wire from the original horn to actuate the relay for the new horn like i think the diagram shows. i just have this feeling that thats whats messed up that it isnt actuating the relay. either that or the whole shebang isnt grounded right. plus the fact that i cant figure out how the fuck this damn system is wired...pos grounded or neg grounded. i tried to look it up on alldata, and it shows the horn as being neg grounded, but who knows im prolly wrong. what should i do?!

i hate and suck at wiring can someone help me out?
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
chill out man, I got ya
you have a + system. Run the green to #85 on the relay, ground #86. Run a constant + to #30(fuses) and #87 to the + of the compressor. If your looking at the bottom of the relay and 3 of the prongs are pointing up and down, # 85 will be on the left ,# 86 on the right, # 30 on the bottom and # 87 on the top
hope this helps
 

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #16
yeah thats what ive been doin i think....i wonder why its not workin...i think its a bad ground
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
what happened?
 

·
Cross Into the Blue
Joined
·
356 Posts
Discussion Starter #19
well i had to wire it up to my high pitch horn wiring. turns out it wasnt the horns that died. the low pitch horn doesnt even get any juice to it, something must be messed up with the wiring, and the high pitch works now....i replaced the fuese lol...
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
so, do you like them or what? Did my wiring help?
 
1 - 20 of 23 Posts
Top