GMC Truck Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
my unit pretty much stopped working.. i had a unit laying around out of a 92.. only thing diff is the 92 has a recir button on it but everything works like it should till i noticed now that after a few min the Cold to hot bar on the screen starts to flash and i cant changed it from hold to cold when it does that.... then when i use defrose the defrose icon starts to flash... why is this doing that or is it just normal?
 

·
Resident Guinea ***
Joined
·
14,535 Posts
There was a bulletin on this:

Bulletin No.: 461202

Date: May, 1994

SUBJECT:
A/C CONTROL HEAD FLASHES OR ERRATIC OPERATION OF A/C CONTROLS (POLISH
TERMINALS)

MODELS:
1988-94 CHEVROLET AND GMC TRUCK C/K MODELS
1990-94 CHEVROLET AND GMC TRUCK TOPKICK/KODIAK MODELS WITH C60 OR C69 AIR
CONDITIONING

CONDITION:

A/C Control Head flashes, performs erratically or malfunctions.

CAUSE:

Light surface corrosion on the Control Head terminals.

CORRECTION:

Remove the A/C Control Head and while holding the unit with the terminal
cavity down (toward the floor) so no particles will fall inside on the
circuit boards, polish the terminals on both sides of the cavity with a lead
pencil pink eraser. Do not use an ink eraser or other abrasive such as a
small wire brush or sandpaper, etc. Doing so will remove the terminal
coating and degrade the contact surface.

Performing this procedure, in many cases, will make replacing the Control
Head unnecessary. Using this procedure in conjunction with the A/C circuit
diagnosis found in the Electrical Diagnosis Manual and especially before
replacing a Control Head for any reason is recommended.

After polishing the Control Head terminals, but before reconnecting, check
for proper terminal contact as described in the applicable electrical
diagnosis manual. If contact is good, apply dielectric grease (P/N 12345579)
to the harness connector terminals. Please do not apply grease to the
Control Head.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #3 ·
well i tried cleaning the terminals and still the same thing.... for the hot to cold bar on the screen, it starts to flash when i put it all the way to cold then it flashes for a min or so then stop and the little moving icon for the bar is gone. now if i move it all the way to hot it comes back and on hot the HOT to COLD bar wont flash at all... so is this normal for the 92 hvac control units?
 
1 - 3 of 3 Posts
Top