GMC Truck Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,481 Posts
Discussion Starter #1
Normal? Looking under the dash of my 06 100K mile Yukon I noticed that the metal collar around the hydroboost was a little wet. It weeps a bit where the rod pushes in. However, under the hood it is as dry as a bone, and the weep hole is also dry. Should I be concerned? Can I replace the inner "O" ring from inside without removing it?

Mr. 960
 

·
Registered
Joined
·
3,481 Posts
Discussion Starter #2
nada??? Mods can you move to maintenance section? Thought I'd get more hits under general discussions.
 

·
Registered
Joined
·
729 Posts
looking at an exploded view of the hydroboost, i don't think it's possible you need to pull the hydroboost and get it on a bench to pull apart and replace.
is it normal... probably for 100k miles. i would keep an eye on it and if it's just damp metal then live it it. when you start seeing actual drops of brake fluid then i would consider a rebuild/replacement of the hydroboost. but you might want to plan on that now to be safe... know where you can either get a rebuild kit with all the orings if you want to do it yourself, or where you can get a whole new unit.
then let me know how it goes because i'm 90 something thousand miles on mine.
 

·
Premium Member
Joined
·
6,277 Posts
Mines a lil moist too :nohomo:
 

·
Registered
Joined
·
3,481 Posts
Discussion Starter #5
It's late and I'm tired, but I did research on where you can find the o rings and rebuild yourself. I'll post up tomorrow. I think for now I'll just monitor it.

Thanks!

Mr. 960
 

·
Registered
Joined
·
743 Posts
Mine leaked down the firewall and occasionally into the cab for about a year before I had it fixed. Just keep an eye on your power steering fluid level.
 
1 - 7 of 7 Posts
Top