GMC Truck Forum banner

181 - 200 of 205 Posts

·
Registered
Joined
·
449 Posts
hey guys, so on my 1999 nbs sierra ive got the 4.3 and the 4l60e, well after driving it in the hot weather now that its getting really hot(live in knoxville tn, and its around 80 or higher now in the day) compared to the winter, well since it has my transmission has developed the issue of after driving it for while(130 plus miles or so) at once and i say get off the interstate when i go to start again from the bottom of the ramp it goes from first into second really really harsly, like a freaking hammer, and is not as bad but still rough in 2-3, and it does this for a while till i get home, well i got home cut the truck off and went inside, came back out like less than 3 minutes later and got back in it and started it to move it around and when i drove around the neighborhood it didnt do it at all, and its not like the truck had time to cool down either really, only thing that "fixed" it was cutting the truck off and back on, what would this be in the trans? a solenoid maybe? any help greatly appreciated
 

·
Registered
Joined
·
1,439 Posts
I believe I have problem 16 :mad:
It sounds like I can hear gears meshing in the trans when in 1st and moving but once it shifts the noise goes away. Once I got home I tried putting it in reverse and nothing. Went back and forth between N and D a couple times then finally it goes into R so hard it felt like the trans wanted to fly out of the truck. Tried to go back to D then and same scenario.
 

·
Duramax Modder
Joined
·
28 Posts
12. Soft shifting, gradual performance degradation: Leaking*boost*valve; clogged EPC filter screen, leaky seals. Transgo kit fixes first two without removing trans. Seal restorer may fix last problem, but probably R&R.
So I've posted here about mine lurching forward after sitting earlier in this thread, it also shifts very lazily into 2nd and soft in other gears (hard for me to judge though my other 2 trucks are Allisons.) The other day I went to take off from an incline and it sat still. I let out of it and tried again then it took off like it should have. Question is what transgo kit are we talking about and what seal restorer is recommended ?
 

·
Duramax Modder
Joined
·
28 Posts
Most noticable when driving is it hangs every gear when downshifting and I swear I feel it kinda let off going down the interstate.
 

·
Registered
Joined
·
1 Posts
Hi I'm new to the forum and came across this thread and was curouis if my issue with my transmission would be the TPS sensor or wiring to it. The truck is a 1995 GMC k1500 SLE, 350 tbi with a 4L60 transmission, the truck with only shift out of 1st if I rev it up to 2,500 RPM and let off the gas and let it idle down but after that it shifts through the rest of the gears normally except when I need pin the throttle. I change the filter and fluid already too
 

·
Registered
Joined
·
62 Posts
While driving to work this morning, was accelerating about 3/4 throttle on 2nd gear, went to shift to 3rd, felt like it went into gear, then the rpms shot up like it was in neutral. Let off the gas and shifted into 3rd with a slight bang and went into 4th fine. The rest of the trip it was fine with no other symptoms. 2010 4.8 with bbp tune.
 

·
woo
Joined
·
218 Posts
So I took a video of mine shifting into 3rd. Doesn't seem like it does it in every gear, mostly notice it going to 3rd.. about half throttle. When it shifts, the RPMs shoot up a little... it doesn't seem normal. It's a 2004 Yukon Denali.


Any help would be great. Thanks
 

·
Just some fuckin guy
Joined
·
2,426 Posts
I have a 93 c1500. There is a shudder when taking off from a stop, and wierd rattling coming from underneath the truck after one pretty bad shudder.
Make sure your tq converter bolts are tight
 

·
Registered
Joined
·
1 Posts
I have a 2009 Silverado 1500 4.3l with about 80K miles. After driving a while, I have experienced a rough 1-2 shift. I've stopped to fill up with gas and the problem disappears for a while. A P0717 code occasionally lights up -- input speed sensor circuit no signal. I found this video on youtube (
). He's basically saying the problem is likely a ground at the TCM and you can re-ground to fix the problem rather than replacing the TCM.

1st, has anybody heard of or tried this fix for P0717?

2nd, does anyone know where to find a color coded wiring diagram to be sure of the correct ground?
 

·
Registered
Joined
·
2,614 Posts
I’d say trash the 60 an put an 80 in with a shift kit
You and so many other people that have never done the swap say that. A 80e swap is a never a cure for a stock or even mild built truck. If you have 500+ hp or 40” tires then you do need it.

Besides that you spend thousands to make you’re truck shift like a 2500hd gasser work truck. If you have enough money to fully build the 80e, you have more than enough to get a 65e.
 

·
Registered
Joined
·
2 Posts
Well son I have an 80 in my half ton an the engine is far from stock, i no longer worry bout that tranny now with the power I’m puttin to it. Good day.
 

·
Registered
Joined
·
4 Posts
Hello, I have an 06 Yukon XL 5.3L 4L60E 125000 miles. I was having a problem with 2nd revving high and having to let off the gas to get it to shift into third as well as cruise control downshifting to 2nd on hills. Now cannot get out of first. Changed fluid, filter and solenoids. I got the code P0752 which led me to replacing the solenoids. Other issue that may be related is that I have am issue with the Traction Control that when going from stop it causes the vehicle to lose power for a short time. Considering replacing the transmission speed sensor. Any help is greatly appreciated.
 

·
Registered
Joined
·
2,614 Posts
Hello, I have an 06 Yukon XL 5.3L 4L60E 125000 miles. I was having a problem with 2nd revving high and having to let off the gas to get it to shift into third as well as cruise control downshifting to 2nd on hills. Now cannot get out of first. Changed fluid, filter and solenoids. I got the code P0752 which led me to replacing the solenoids. Other issue that may be related is that I have am issue with the Traction Control that when going from stop it causes the vehicle to lose power for a short time. Considering replacing the transmission speed sensor. Any help is greatly appreciated.
Speed sensor is magnetic. Meaning there’s so much clutch material on that sensor it can not read. It’s toast. You’re p0752 is cruise crontrol.
 

·
Registered
Joined
·
2,614 Posts
What is toast? The transmission speed sensor or the transmission. P0752 is shift solenoid A stuck on.
my time. Keep us up to date.
 

·
Registered
Joined
·
4 Posts
Hello, I have an 06 Yukon XL 5.3L 4L60E 125000 miles. I was having a problem with 2nd revving high and having to let off the gas to get it to shift into third as well as cruise control downshifting to 2nd on hills. Now cannot get out of first. Changed fluid, filter and solenoids. I got the code P0752 which led me to replacing the solenoids. Other issue that may be related is that I have am issue with the Traction Control that when going from stop it causes the vehicle to lose power for a short time. Considering replacing the transmission speed sensor. Any help is greatly appreciated.
I read that the speed sensor will cause the speedometer to malfunction and mine is working correctly. Not sure if it means my speed sensor is working properly or not.
 

·
Registered
Joined
·
7 Posts
What is toast? The transmission speed sensor or the transmission. P0752 is shift solenoid A stuck on.
Go to the junk yard buy a $300 transmission and use your old transfer case on the new one... have fun with the top bell housing bolts.... exhaust bolts are a lot easier when you jack the tranny up off them and relieve some weight😜ran my 05 Tahoe till it only had 2 gears and I still could get it up to 50 for beer runs to town haha it wouldn’t even shift from park unless I put the parking brake on. Even with little to no experience you can change that transmission I did two already one in a 99 suburban and the other in the 05 Tahoe and the suburban was wayyy easier
Edit; then found out it was the transfer case that was split in half on the burban and the tranny was fine
 

·
Some dude on the internet
Joined
·
868 Posts
Go to the junk yard buy a $300 transmission and use your old transfer case on the new one... have fun with the top bell housing bolts.... exhaust bolts are a lot easier when you jack the tranny up off them and relieve some weight😜ran my 05 Tahoe till it only had 2 gears and I still could get it up to 50 for beer runs to town haha it wouldn’t even shift from park unless I put the parking brake on. Even with little to no experience you can change that transmission I did two already one in a 99 suburban and the other in the 05 Tahoe and the suburban was wayyy easier
Edit; then found out it was the transfer case that was split in half on the burban and the tranny was fine
Spending 300 bucks on a junkyard 60e is like buying a book of lottery tickets to fund your new refrigerator. You might get lucky, but more than likely end up 300 bucks poorer with a pile of dust and tears on the ground. Save up and get a rebuild or 65e.
 
181 - 200 of 205 Posts
Top