GMC Truck Forum banner

1 - 6 of 6 Posts

·
Drag Racer!
Joined
·
1,158 Posts
Discussion Starter #1
heres my prob. i went today to start my jeep to take it to get numbers on a trade for that black '02 Z71. At first my battery was dead so i jumped it and started my jeep. Then i put some power steering fluid in it because some had leaked out. After that i had it on cold idle to charge the battery and out of nowhere my jeeps engine started to idle funny, like it would bog down then rev back up to idle continuesly. when i kicked it down to warm idle it died. Now, everytime i start it i need to give it gas. Possibility of fuel pump gone?? Also, when i rev it the jets give the carb fuel, but when i stop i dont see them feeding it. I also think in the back of my mind that my timing may have jumped?? I need some input as id like to get it running again. TIA guys
 

·
Registered
Joined
·
1,816 Posts
Sounds like the carb is doing something silly to me. I'd go thru and check the vacuum lines and stuff. On top of that, I don't know shit about carbs :D
 

·
Drag Racer!
Joined
·
1,158 Posts
Discussion Starter #3
eh....i didnt tough any vacuum lines on it, but it HAS been leaking fuel out of the carb, never effected the running condition of the vehicle though
 

·
Banned
Joined
·
487 Posts
Now, everytime i start it i need to give it gas.
You mean pour gas down the carb, hold your pedal to the floor, pump it, or just push it in a little ways?

Sounds just like what my 454 did.... im replacing fuel pump, right after my carburater gets the fire extinguisher crap cleaned out of it :pow:
 

·
Drag Racer!
Joined
·
1,158 Posts
Discussion Starter #6
i have an update on my jeep......it will run when the choke butterfly is closed, when i open it up to where its supposed to be for warm idle the engine chokes and dies. maybe this will help you guys diagnose my quadrajunk probs
 
1 - 6 of 6 Posts
Top