GMC Truck Forum banner

1 - 20 of 36 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have and 08 with 210,000 miles on it. I have a lifter ticking on the drivers side but it doesn't tick all the time. Doesn't tick when cold. and sometimes when hot.
I changed the plugs and the old ones looked good with no sign of oil on them. I had a shop check the oil pressure they said it was within specs. I've thought about just buying a jasper engine or should I put lifters in it? I just don't know what to do.I have helped my son put cam and lifters in a ls1 so i'm wondering if the 5.3 iron block will be the same or should I seek help. Thanks for your advise and suggestions.
 

·
Timbrage: Engage
Joined
·
5,659 Posts
what motor? is it an AFM or displacement on demand motor? its common for these things to drop AFM lifters, but could also be as simple as a cracked exhaust manifold or a small exhaust leak
 

·
Premium Member
Joined
·
6,277 Posts
Remove the valve cover, get some B12 chemtool and remove the rockers...spray down the push rods so it gets on the lifters....torque the rocker bolts to 22ft lbs and u should be good.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
what motor? is it an AFM or displacement on demand motor? its common for these things to drop AFM lifters, but could also be as simple as a cracked exhaust manifold or a small exhaust leak
Thanks. I'm not sure how to tell which engine it is. I know it's "J" code on the vin.
 

·
Premium Member
Joined
·
6,277 Posts
sometimes the lifters and pushrods get some gunk built up and will block the tiny oil passage. the B12 will clean it right up and you should be good if that was ur problem. If u have J code, u have an LY5 which has the AFM and one of those AFM lifters might be collapsing after being activated. LY5s are known for losing lifters and damaging the cam lobes, push rods and rockers. Get this sorted out before you cause any/more damage.
 

·
Premium Member
Joined
·
6,277 Posts
btw, the 5.3 will be just like an LS1 to work on...heads have to come off to replace the lifters. Youd need 8 AFM and 8 regular lifters. Or you can delete it with kits sold from vendors on here and all over the place. Might have to replace the cam if the lobes are messed up, not necessary if it looks good. I just did lifters on a non-AFM 5.3 with 154k miles. The owner complained about a tick. I found 1 pushrod that had a mushroom'd head from a lifter collapsing and the poor thing just rattling around. Replaced all 16 lifters, head gaskets, knock sensors, valve seals and gaskets....good as new.
 

·
Damn Nice Guy
Joined
·
73 Posts
Pretty sure all 08 5.3s are going to be AFM, 4.8 and 6.2 are non-AFM.
 

·
Registered
Joined
·
6 Posts
CW1500, I had the exact same issue with my '05 crewcab. Would only tap between 100* - 200* then go away... Eventually it started ticking randomly for longer periods. I did a ton of research and one thing I found was a buliton from GM regarding an oring at the oil pump that causes cavitation in the pump. I noticed the oil psi was lower (but still at a safe pressure) during the ticking. Last month I decided to tear into it and replaced the oil pump with a high volume/high pressure unit from melting AND replaced that o-ring. Now I have 40psi at idle and 60psi off idle and best of all - NO MORE TICKING!
 

·
Premium Member
Joined
·
2,287 Posts
The 6.0 in my '08 Silverado is an AFM motor. Don't think there was a 6.2L engine in the 2008 trucks.
Wrongo, there was 6.2 in 08
 

·
Registered
Joined
·
1,004 Posts
6.0 was only in 07 and 08 trucks. The 6.2 was only available in yukon denali, escalade, and sierra denali. Once GM dropped the 4l60e for the 6l80e in 09 for trucks with a 5.3 and larger motor and dropped the 6.0 all together in the 1500's and replaced them with the 6.2
 

·
Premium Member
Joined
·
2,287 Posts
6.0 was only in 07 and 08 trucks. The 6.2 was only available in yukon denali, escalade, and sierra denali. Once GM dropped the 4l60e for the 6l80e in 09 for trucks with a 5.3 and larger motor and dropped the 6.0 all together in the 1500's and replaced them with the 6.2
Sounds like a wiki quote :insane2:
 

·
Premium Member
Joined
·
6,277 Posts
csb but this isn't a "when did the 6.2L come out?" thread
 

·
Registered
Joined
·
1,004 Posts
Sounds like a wiki quote :insane2:
Haha thats just what I have learned from this site over the last 2 years. You beat my two minutes lol.

csb but this isn't a "when did the 6.2L come out?" thread
Well the guy that replyed before beckmand78 replied to the thread was all confused about the 6.2 liter so I just wanted to clarify for him.
 

·
Central Florida Chapter
Joined
·
175 Posts
I don't think i would trust a jasper engine haha, just personal experience, but maybe he just gave up and due to mileage, just easier to replace?
 
1 - 20 of 36 Posts
Top