GMC Truck Forum banner

1 - 9 of 9 Posts

·
CENTEXOFFROAD
Joined
·
1,348 Posts
Discussion Starter · #1 ·
Ok, so my truck has been giving me a couple of problems lately.
First, sometimes when I first start driving my truck, the speedo is dead, and the tranny won't shift out of 1st, but then the speedo picks up and it shifts and drives normal, a couple of times it has turned on an ABS light, but I don't have access to a scan tool to read the codes, well, now, when I left work today, it did the same thing but it went into limp in mode and wouldn't shift out of 2nd, it sucked because I am trying to get over the lake to get back home and trying to stay with the flow of traffic at 60 and im in 2nd, 4k over a 1/2 mile bridge sucks, well, I went to Oreilly's and priced a couple of parts, and I got back into my truck to drive home and everything works normal...WTF, I'm getting ready to burn my truck to the ground. Any suggestions, I'm thinking speed sensor or wiring, hopefully something simple like that.

TIA

Josh
 

·
CENTEXOFFROAD
Joined
·
1,348 Posts
Discussion Starter · #3 ·
I don't have much money, and I don't want to drop the money right away for something that might not fix the problem, I was hoping someone has ran into this problem before and maybe knows how to fix it.
 

·
GMFS slowest truck :read:
Joined
·
5,501 Posts
speed sensors are cheap. i almost guarantee thats the prob.
 

·
CENTEXOFFROAD
Joined
·
1,348 Posts
Discussion Starter · #6 ·
yes, I know how much it is, its 100 bucks, I am gonna hope its not that. It might be easy for you to drop 100 but not me. At least not at the moment. Maybe its the wire pigtail, I don't know.
 

·
Is not a liberal
Joined
·
22 Posts
I was reading through 4l60e stuff last night (trying to diagnose my own transmission) and I saw this exact problem and it said replace VSS, so drop the 100 bones and get it over with. Be glad you don't need a new tranny.
 

·
Banned
Joined
·
1,500 Posts
Be glad you don't need a new tranny.
im with this guy

yes, I know how much it is, its 100 bucks, I am gonna hope its not that. It might be easy for you to drop 100 but not me. At least not at the moment. Maybe its the wire pigtail, I don't know.
have any friends that work at parts stores?
 
1 - 9 of 9 Posts
Top