GMC Truck Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I've got a 99 Silverado LT ext cab that I bought about a month ago and have been happy with it so far,but yesterday the fuel & temp gauges would quit working for no reason every so often.When this happened the message center would flash the battery,low fuel and security lights in sequence.I had a mechanic scan it and there were some codes retrieved but we could not identify them so I will put them here in hopes that someone else can or tell me what the problem might be.P1626,U1026,U1064,U1301.Now today everthing seems to be working fine so I'm not sure wether it was a glitch somewhere or what but I would like some info if it's available.Thanks.
 

·
Registered
Joined
·
6,224 Posts
I've had a glitch kinda like that too. Cept my message control center said that I had no oil pressure and the gauge wouldn't work either. But everything is fine now.
 

·
Registered
Joined
·
785 Posts
he had it scanned and they couldn't find out what the codes were from what he wrote, also to bad you don't have a predator programmer it would tell you what the codes were even though a lot of people on this site don't like them
 

·
Premium Member
Joined
·
741 Posts
is the truck lowerd ? if so i have that same prob it is a bad ground some where around the trans every time i hit the ground it does the same thing or when it rains ...... someone told me in was a ground some where by the trans.

Hope this helps
 

·
Loves yoga pants
Joined
·
2,412 Posts
Erratic gas gauge is notoriously a fuel pressure sending unit going out. Not sure why the message center is dorkin out on ya though. I'll check my Haynes manual tonight to give ya descriptions for the codes.

Pat
 

·
Registered
Joined
·
42 Posts
I have that same EXACT problem with my 2001 Silverado. It happened right after I had a friend install an alarm in my truck. I thought that he shorted something. My gas gauge is dead, my temp gauge is dead, my message center stays on the battery symbol and to make things worse, my odometer/gear indicator screen only works in the accessory position.(shuts off when the truck is running) Please post anything that you find out. I need to fix this too. I already ran out of gas on the freeway once. Everyone I ask knows nothing about it and I dont want to spend the $100-300 for a shop to just tell me that there is nothing they can do. HELP!
 

·
Registered
Joined
·
110 Posts
Mine does the exact same thing. It started doing it after a shop installed a keyless entry system on my truck. One shop said the computer needed to be reflashed, but then the dealer told me I needed a new gauge cluster for $500 needless to say its still broken.
 
1 - 14 of 14 Posts
Top