GMC Truck Forum banner

1 - 20 of 26 Posts

·
Cartmans Critters
Joined
·
8,871 Posts
Discussion Starter #1
Ok so the peg that goes into the drill is round, well when I put pressure on it I cant get the damn thing to hold on to it, itll just stop spinning cause the drill cant get a good hold on the peg......Is there a fitting out there to fix this problem?
 

·
Mrs. W.
Joined
·
111 Posts
Aaron owns one he just hasn't used it yet. we are having a hard time getting the polish for it. is there other stuff you can use or does it have to be the mother's polish stuff?
 

·
Cartmans Critters
Joined
·
8,871 Posts
Discussion Starter #6
Aaron owns one he just hasn't used it yet. we are having a hard time getting the polish for it. is there other stuff you can use or does it have to be the mother's polish stuff?
I used mothers power metal and Ive tried mothers chrome polish, both have given the rims equal shine.
 

·
Registered
Joined
·
98 Posts
Mine fits in my 3/8" just fine, Havent had a problem yet and have used quite a bit of pressure. Maybe your grips are wearing out on the drill or you didnt tighten it enough once so it wore the powerball tip. Just some thoughts.
 

·
Cartmans Critters
Joined
·
8,871 Posts
Discussion Starter #9
Mine fits in my 3/8" just fine, Havent had a problem yet and have used quite a bit of pressure. Maybe your grips are wearing out on the drill or you didnt tighten it enough once so it wore the powerball tip. Just some thoughts.
The drills brand new :bawl: It doesnt have a chuck to tighten it just tightens by hand, maybe thats where I went wrong?
 

·
Registered
Joined
·
1,492 Posts
Take a grinder and grind some flat spots evenly around the shaft that goes into the drill. that should keep it from slipping. I had the same problem with mine.
 
1 - 20 of 26 Posts
Top