GMC Truck Forum banner

1 - 20 of 33 Posts

·
Respect mah authoritah!
Joined
·
11,152 Posts
Discussion Starter · #1 ·
Just as the title states, I was driving home from work yesterday listening to a CD, and out of no where the sound cuts off! The radio is still powered on, so I try to change it to the radio and then to satellite radio, nothing. I turn it off and back on, but still nothing.

Left it alone b/c I didn't feel like tearing into my dash last night. Jumped in my truck this morning and popped in a new CD I made last night, and it worked for about 3 minutes, then cut off again!


I have no clue what to do. I could understand if the whole radio cut off, but it's not! It's just the sound, everything else on the radio works.


If it matters, it's an in-dash Jensen dvd player that I've had for a couple years with no problems whatsoever!


Please help! I gotta have my music! Do I need to look into buying a new headunit? :bawl:
 

·
Mossy Oak Pro Staff
Joined
·
2,668 Posts
IDK shit about stereos but it sounds like a loose connection to me.
 

·
Fresno State Bulldog
Joined
·
5,708 Posts
Are you running the speakers off the deck? Or an amp? If you're running an amp, check the RCA's and ground to the amp, if not, the internal amp on the deck may be on its way out :shrug:
 

·
Respect mah authoritah!
Joined
·
11,152 Posts
Discussion Starter · #4 ·
Are you running the speakers off the deck? Or an amp? If you're running an amp, check the RCA's and ground to the amp, if not, the internal amp on the deck may be on its way out :shrug:
off the deck. and yeah, I think it's just finally turded out on me. :(
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
sounds like a bad speaker or grounding out wire. Next time it does that, fade it to the front, turn it off and back on again. If the sound comes back, fade it to the rear and see if it cuts off, if so you have a rear speaker problem. Than keep it to the rear, balance to the left, turn it off and on again. If the music returns, you probably have a bad right rear. Just testing it like that can lead to your issue, well other than it being a Jensen that is
 

·
Respect mah authoritah!
Joined
·
11,152 Posts
Discussion Starter · #6 ·
sounds like a bad speaker or grounding out wire. Next time it does that, fade it to the front, turn it off and back on again. If the sound comes back, fade it to the rear and see if it cuts off, if so you have a rear speaker problem. Than keep it to the rear, balance to the left, turn it off and on again. If the music returns, you probably have a bad right rear. Just testing it like that can lead to your issue, well other than it being a Jensen that is
ROFL, ok sweet! I'll try that at lunch! thanks bud!


If that doesn't work, i should take my dash off and check connections on all the speakers?
 

·
Respect mah authoritah!
Joined
·
11,152 Posts
Discussion Starter · #7 ·
bump anyone else?

if it's the amp in my radio, can i hook an amp up to it and in theory it work?
 

·
Respect mah authoritah!
Joined
·
11,152 Posts
Discussion Starter · #8 ·
So an update.

I did like you said forklift and tried everything out. I even took the dash off just to check all the connections. Still no sound.


I get in my truck this morning, and it works. BUT, it only works for about 3-5 minutes before not playing music anymore.

This would lead me to believe it was the amp in the radio right? And I can run an amp to the speakers and I wouldn't have to buy a new headunit right?
 
G

·
I wouldn't trust that head unit :imo

It's a Jensen, and you got a couple good years of service out of it. I'd chalk that up as a win and upgrade.
 

·
Fresno State Bulldog
Joined
·
5,708 Posts
I wouldn't trust that head unit :imo

It's a Jensen, and you got a couple good years of service out of it. I'd chalk that up as a win and upgrade.
:word: I wouldn't go out and buy an amp, try and find someone with an extra amp laying around and try it, if it works, then get one, otherwise get another HU :D
 

·
Stay Gold!!!!
Joined
·
6,522 Posts
Test it out on the workbench like I said with the RCA's.

Honestly, I'd just pick up a new radio. You can only get a few years of usage out of electronics these days no matter what they are.
 

·
Respect mah authoritah!
Joined
·
11,152 Posts
Discussion Starter · #12 ·
:bawl: i loved my jensen


ill see if anyone has an extra CD player. if not, guess ill just have to listen to my ipod on my phone :biggrin:
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
as far as using an amp, who knows. The preamp could be dead or the amp itself. If its the preamp then an actual amp wont help, but I am selling one
 

·
Stay Gold!!!!
Joined
·
6,522 Posts
as far as using an amp, who knows. The preamp could be dead or the amp itself. If its the preamp then an actual amp wont help, but I am selling one
I recommended on the phone that he powered up the head unit on a workbench, then run an rca from the head unit to a home stereo received input, such as cd. That should tell him if the pre-amp section works without wiring up an amp.
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
I recommended on the phone that he powered up the head unit on a workbench, then run an rca from the head unit to a home stereo received input, such as cd. That should tell him if the pre-amp section works without wiring up an amp.
or tie in some headphones and crank it, rcas will slightly drive a set
 

·
:bishplz:
Joined
·
5,053 Posts
Since it works for a few mins, could it be overheating? The next day when he gets in the truck it has cooled off but quickly heats up again? Make sure any fans in there are functioning and whatnot and there isn't a shitload of dust or anything stuck in them. Just a thought :shrug: heat could cause the little amp inside to overheat and cut out I'd imagine.
 

·
Wanna B Jack o all Trades
Joined
·
9,823 Posts
1 - 20 of 33 Posts
Top