GMC Truck Forum banner
1 - 8 of 8 Posts

·
billet
Joined
·
903 Posts
Discussion Starter · #1 · (Edited)
so this is an older picture, (from a prior thread) but the orange wire and plug are worse off now, more burnt.... Trying to find a fix for this, perhaps a pigtail assembly? this goes into the back of the interior fuse block

 

·
billet
Joined
·
903 Posts
Discussion Starter · #2 · (Edited)

·
Registered
1999 Silverado ECSB 6.0
Joined
·
776 Posts
My first thought is yes possibly needs a new pigtail assembly. Are you able to follow the wire that is getting burnt? It looks like it is burning at the connector but it could be shorting out somewhere.
 

·
billet
Joined
·
903 Posts
Discussion Starter · #4 ·
My first thought is yes possibly needs a new pigtail assembly. Are you able to follow the wire that is getting burnt? It looks like it is burning at the connector but it could be shorting out somewhere.
yeah at minimum I'd like to do a new pigtail for sanity sake. Albeit the orange wire i believe is the same one that runs up to the ignition in the column. Having a difficult time finding the harness (found the GM version on eBay, says 1 left, i buy it, they message me tonight telling me that it's on backorder) smh lol.
 

·
Registered
1999 Silverado ECSB 6.0
Joined
·
776 Posts

·
billet
Joined
·
903 Posts
Discussion Starter · #7 ·

This and replace wire perhaps.
ahh didnt even think of unpin and do that, gotta find my set anyways for future use.

ironically my buddy is junking a NBS silverado, cut the pigtail off that one so I have the actual plug AND after a random inquiry on the BookOFace found the pigtail new from Napa. PN# EC690


 
1 - 8 of 8 Posts
Top