GMC Truck Forum banner

1 - 5 of 5 Posts

·
eBay-aholic
Joined
·
510 Posts
Discussion Starter #1
I was driving my 02 1500HD (with 110k miles) last night, and when I went to take off at a light, the truck all of a sudden bogged down, and barely moved. I was able to get it to the side of the road, and let it sit for a couple minutes. Everything looks normal under the hood, and I didn't smell anyhing out of the ordinary or see any leaks. When I tried start it, it turned over, but the RPM's are really low (below 500). I've got a 1/2 tank of gas, oil pressure gauge is normal, and no diagnostic gauges are lit.

I was out of town, but luckily I have AAA Emergency Road Service with the free 100 mile tow, so I had it towed to my local Chevy dealership.

From what I've read on the forums, it sounds like either the fuelpump is going out or the fuel filter is clogged. Also, I have the bad habit of running the tank to E before filling up :banghead:.

What can I expect the dealership to charge me to get it fixed and running?
 

·
Registered
Joined
·
277 Posts
If it's the fuel pump, about $600-700. These dealers have changed out so many they have it down to a science. Takes about a hour and a half but they charge the full book time of 4-5 hours.
 

·
resident pyromaniac
Joined
·
7,499 Posts
seriously man, dont waste your money having them install it. it only takes about an hour to do it all with the help of 3 or 4 buddies. simply unbolt the filler neck from the side of the bed and unbolt the 8 bolts that mount the bed (they're under the bottom obviously) and remove the taillights/unplug harnesses. Now remove the bed and replace the fuel pump. its simple!
 

·
eBay-aholic
Joined
·
510 Posts
Discussion Starter #4
:whoa: $540 for labor and $500 for the fuelpump and fuelfilter. The fuelpump went bad, but I ended up having them replace the fuelfilter anyways. I ended up having the dealership do the work, since I already had it towed there. :(
 

·
GMFS Member
Joined
·
913 Posts
yea man that's definitely whats wrong I had the same problem with my truck. After it warmed up it would start to bog down but as soon as I turned it off then turn it back on it would run right for a few minutes
 
1 - 5 of 5 Posts
Top