GMC Truck Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Just picked up a 05 Sierra CC. Rebuilt lm7 with a stage 3 cam, long tubes, flat top pistons.

Motor runs strong and sounds good. Rpms at about 2k running 70.
Around town though it runs high Rpms when coasting around. Previous owner says it was tuned at a shop in NWA. I know it needs a new transfer case encoder cause it only stays in auto 4wd. But it seems to run really odd around town. Do you all think it could use a re-tune by blackbear?
 

·
Some dude on the internet
Joined
·
239 Posts
Hard to tell without seeing the tune - they may have changed your upshift speed and rpm tables when they tuned it.
 

·
Registered
Joined
·
41 Posts
Discussion Starter #3
I emailed the company that did it in Arkansas to see if they have records on it . On the highway it runs great, smooth and plenty of power.

But driving around town, it's like the cruise is on and it never slows down until you get on the brake, no gradual slow down when you let off the gas.

Sometimes it idles kinda high sporadically then drops back down. Did these have throttle position sensors?
 

·
Registered
Joined
·
41 Posts
Discussion Starter #4
Would my exhaust setup have anything to do with the lack of low end around town and odd running tendencies? I have LT headers, true dual 3" with an xpipe and dual vibrant resonators to two vibrant mufflers.

I was considering replacing the x pipe with a Y and make it a single 3" exhaust all the way back.
 

·
Mmm Sandwich
Joined
·
15,020 Posts
Fix what is wrong and have your tune looked at. But no low end is subjective with nothing to back it up.

Yet your can is not really a tq cam. Also does your truck have any tranny work done? I am wondering if your truck is hurting for a converter
 

·
Registered
Joined
·
41 Posts
Discussion Starter #8
It has a vette servo in it. Could it be too big an exhaust setup with true dual 3"? I was considering putting a y in and running single 3"
 

·
Mmm Sandwich
Joined
·
15,020 Posts
It has a vette servo in it. Could it be too big an exhaust setup with true dual 3"? I was considering putting a y in and running single 3"
Your power band isn't down low with that cam. Not going to change anything putting smaller tube in. Again having your tc engaged all the time is sucking power too.

Do yourself a favor and fix that and find out about your tune. Don't waste your money until than. Also if the servo is all that is done I am sure that trans is begging for a converter.
 
1 - 9 of 9 Posts
Top